IS-IS
所有连续的L2或者L1-2构成IS-IS的逻辑骨干区。
IIH IS-IS间的HELLO包
Integrated IS-IS NSAP Address Structure
--IDP--- ----------------------DSP--------------------
AFI IDI High-Order DSP System ID NSEL
|<--------Variable-Lenagth----->|<----6Bytes--->|1Byte|
Area Address
IDP(Initial Domain Part)
AFI(Authority Format ID) [1Byte]
49(私有,16进制)
IDI(Initial Domain ID) [Variable-Length]
47.0005
47.0006
DSP(Domain Sepcific Part)
HODSP(Area) [Variable-Length]
System ID(IP/MAC) [6Byte]
NSAP-Selector (0x00) [1Byte]
如:Public IP
202.1.3.10
202.001.003.010
2020.0100.3010
NSAP地址规划
必须要以一个字节开始,以一个字节结束。
如:49.0001.0000.0c22.2222.00
R1(config)#router isis
R1(config-router)#net 49.0001.1111.1111.1111.00 //配置NET地址
R1(config-router)#log-adjacency-changes all //当邻居DOWN时log提示
R1(config)#interface s1/0 //将接口通告进ISIS
R1(config-if)#ip route isis
R1(config-if)#isis metric 5 //修改metric值选路
R1(config-if)#isis circuit-type level-1/1-2/2-only //将层次细化到某个接口
R1#show clns neighbors //查看ISIS邻居
R1#show isis hostname //查看System ID与Hostname映射表
R1#show isis database //查看ISIS数据库
R1#show isis database verbose //查看ISIS数据库明细
R1#show clns is-neighbors
R1#show clns interface
R1#show clns protocol
清除ISIS邻居:
R1#clear isis * //清除ISIS所有信息
R1#clear clns neighbors //清除ISIS邻居信息
ISIS优化:
R2(config)#router isis
R2(config-router)#is-type level-1
R3(config)#router isis
R3(config-router)#is-type level-2
Route Leaking(路由泄漏)
R1(config-router)#redistribute isis ip level-2 into level-1 distribute-list 100
R1(config)#access-list 100 permit ip 3.3.3.0 0.0.0.0 any
封装:
UDP RIP
IP EIGRP
IP OSPF
L2H ISIS
组播地址:
Level-1: 01:80:C2:00:00:14
Level-2: 01:80:C2:00:00:15
IS-IS PDUS(IS-IS报文):
Hello(ESH,ISH,IIH)
LSP
PSNP(Partial sequence number PDU) LSR/ACK
CSNP(Complete sequence number PDU) DBD
IS-IS Network Type:
PSNP CSNP
Broadcast Request(LSR) 由DIS每10S发一次
Point-to-Point ACK 邻居建立只发一次
DIS选举方式:
1.Highest interface priority(较高优先级) 64
2.Highest SNPA(MAC) breaks ties
ISIS配置实验:
R2(s1/0)------(s1/0)R1(s1/1)------(s1/0)R3
配置脚本:
----R1----------------------------------------------------------------------
R1#sh run
Building configuration...
Current configuration : 1307 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
!
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
voice call carrier capacity active
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
ip router isis
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 12.1.1.1 255.255.255.0
ip router isis
serial restart_delay 0
!
interface Serial1/1
ip address 13.1.1.1 255.255.255.0
ip router isis
serial restart_delay 0
!
router isis
net 49.0001.1111.1111.1111.00
log-adjacency-changes all
!
ip classless
no ip http server
!
!
call rsvp-sync
!
!
mgcp profile default
!
dial-peer cor custom
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
---R2-----------------------------------------------------------
R2#sh run
Building configuration...
Current configuration : 1280 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
!
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
voice call carrier capacity active
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
ip router isis
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 12.1.1.2 255.255.255.0
ip router isis
serial restart_delay 0
!
router isis
net 49.0001.2222.2222.2222.00
log-adjacency-changes all
!
ip classless
no ip http server
!
!
call rsvp-sync
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
----R3-----------------------------------------------------------
R3#sh run
Building configuration...
Current configuration : 1280 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
!
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
voice call carrier capacity active
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
ip router isis
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 13.1.1.3 255.255.255.0
ip router isis
serial restart_delay 0
!
router isis
net 49.0001.3333.3333.3333.00
log-adjacency-changes all
!
ip classless
no ip http server
!
!
!
!
!
call rsvp-sync
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
-------------------------------------------------------------------------------
测试:
R3# ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/92/160 ms
R3#