OSPF Virtual-Link Configuration
Virtual-link in area 1
R1
R1#show running-config
Building configuration...
Current configuration : 850 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
interface Serial0/0
ip address 12.1.1.1 255.255.255.0
serial restart-delay 0
!
interface Serial0/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 12.1.1.1 0.0.0.0 area 0
!
ip http server
no ip http secure-server
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
R1#
R2
R2#show running-config
Building configuration...
Current configuration : 940 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
interface Serial0/0
ip address 12.1.1.2 255.255.255.0
serial restart-delay 0
clock rate 64000
!
interface Serial0/1
ip address 23.1.1.1 255.255.255.0
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
area 1 virtual-link 3.3.3.3
network 12.1.1.2 0.0.0.0 area 0
network 23.1.1.1 0.0.0.0 area 1
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
R2#
R3
R3#show running-config
Building configuration...
Current configuration : 940 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
interface Serial0/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/1
ip address 23.1.1.2 255.255.255.0
serial restart-delay 0
clock rate 64000
!
interface Serial0/2
ip address 34.1.1.1 255.255.255.0
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
area 1 virtual-link 2.2.2.2
network 23.1.1.2 0.0.0.0 area 1
network 34.1.1.1 0.0.0.0 area 2
!
ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
R3#
R4
R4#show running-config
Building configuration...
Current configuration : 868 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
interface Serial0/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/2
ip address 34.1.1.2 255.255.255.0
serial restart-delay 0
clock rate 64000
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
router-id 4.4.4.4
log-adjacency-changes
network 34.1.1.2 0.0.0.0 area 2
!
ip http server
no ip http secure-server
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
R4#