|
命令
|
目的
|
Step 1
|
configure terminal
|
进入配置状态
|
Step 2
|
interface range
{port-range}
|
进入组配置状态
|
Step 3
|
|
可以使用平时的端口配置命令进行配置
|
Step 4
|
end
|
退回
|
Step 5
|
show interfaces
[interface-id]
|
验证配置
|
Step 6
|
copy running-config startup-config
|
保存
|
|
Switch# configure terminal
Switch(config)# interface range fastethernet0/1 - 5
Switch(config-if-range)# no shutdown
Switch(config-if-range)#
*Oct 6 08:24:35: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Oct 6 08:24:35: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to up
*Oct 6 08:24:35: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to up
*Oct 6 08:24:35: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state to up
*Oct 6 08:24:35: %LINK-3-UPDOWN: Interface FastEthernet0/5, changed state to up
*Oct 6 08:24:36: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/05,
changed state to up
*Oct 6 08:24:36: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed
state to up
*Oct 6 08:24:36: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed
state to up
Switch# configure terminal
Switch(config)# interface range fastethernet0/1 - 3, gigabitethernet0/1 - 2
Switch(config-if-range)# no shutdown
Switch(config-if-range)#
*Oct 6 08:29:28: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Oct 6 08:29:28: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to up
*Oct 6 08:29:28: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to up
*Oct 6 08:29:28: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed state to up
*Oct 6 08:29:28: %LINK-3-UPDOWN: Interface GigabitEthernet0/2, changed state to up
*Oct 6 08:29:29: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/ 1,
changed state to up
*Oct 6 08:29:29: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/ 2,
changed state to up
*Oct 6 08:29:29: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/ 3,
changed state to up
|
命令
|
目的
|
Step 1
|
configure terminal
|
进入配置状态
.
|
Step 2
|
interface
interface-id
|
进入端口配置状态
.
|
Step 3
|
speed
{10 | 100 | 1000 | auto | nonegotiate}
|
设置端口速率
注
1000 只工作在千兆口
. GBIC模块只工作在
1000 Mbps下
. nonegotiate 只能在这些
GBIC上用
1000BASE-SX, -LX, and -ZX GBIC.
|
Step 4
|
duplex
{auto | full | half}
|
设置全双工或半双工
.
|
Step 5
|
end
|
退出
|
Step 6
|
show interfaces
interface-id
|
显示有关配置情况
|
Step 7
|
copy running-config startup-config
|
保存
|
Switch# configure terminal
Switch(config)# interface fastethernet0/3
Switch(config-if)# speed 10
Switch(config-if)# duplex half
|
命令
|
目的
|
Step 1
|
configure terminal
|
进入配置模式
|
Step 2
|
interface
interface-id
|
进入要加入描述的端口
|
Step 3
|
description
string
|
加入描述
(最多
240个字符
).
|
Step 4
|
end
|
退回
.
|
Step 5
|
show interfaces
interface-id
description
or
show running-config
|
验证
.
|
Step 6
|
copy running-config startup-config
|
保存
|
|
Switch# config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface fastethernet0/4
Switch(config-if)# description Connects to Marketing
Switch(config-if)# end
Switch# show interfaces fastethernet0/4 description
Interface Status Protocol Description
Fa0/4 up down Connects to Marketing
|
Note
当生成一个
interface Vlan
时,只有当把某一物理端口分配给它时才能被激活
|
|
命令
|
目的
|
Step 1
|
configure terminal
|
进入配置状态
|
Step 2
|
interface
{{fastethernet | gigabitethernet} interface-id} | {vlan vlan-id} | {port-channel port-channel-number}
|
进入端口配置状态
|
Step 3
|
no switchport
|
把物理端口变成三层口
|
Step 4
|
ip address
ip_address subnet_mask
|
配置
IP地址和掩码
|
Step 5
|
no shutdown
|
激活端口
|
Step 6
|
end
|
退出
|
Step 7
|
show interfaces
[interface-id]
show ip interface
[interface-id]
show running-config interface
[interface-id]
|
验证配置
|
Step 8
|
copy running-config startup-config
|
保存配置
|
|
Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface gigabitethernet0/2
Switch(config-if)# no switchport
Switch(config-if)# ip address 192.20.135.21 255.255.255.0
Switch(config-if)# no shutdown
Switch(config-if)# end
Switch# show ip interface gigabitethernet0/2
GigabitEthernet0/2 is up, line protocol is up
Internet address is 192.20.135.21/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
<output truncated>
Show Commands for Interfaces
Command
|
目的
|
show interfaces
[interface-id]
|
显示所有端口或某一端口的状态和配置
.
|
show interfaces
interface-id status [err-disabled]
|
显示一系列端口的状态或错误-关闭的状态
|
show interfaces
[interface-id] switchport
|
显示二层端口的状态,可以用来决定此口是否为二层或三层口。
|
show interfaces
[interface-id] description
|
显示端口描述
|
show ip interface
[interface-id]
|
显示所有或某一端口的
IP可用性状态
|
show running-config interface
[interface-id]
|
显示当前配置中的端口配置情况
|
show version
|
显示软硬件等情况
|
|
Switch# show interfaces status
Port Name Status Vlan Duplex Speed Type
Gi0/1 connected routed a-full a-100 10/100/1000Base
TX
Gi0/2 wce server 20.20.2 disabled routed auto auto 10/100/1000Base TX
Gi0/3 ip wccp web-cache notconnect routed auto auto 10/100/1000Base TX
Gi0/4 notconnect routed auto auto 10/100/1000Base TX
Gi0/5 notconnect routed auto auto 10/100/1000Base TX
Gi0/6 disabled routed auto auto 10/100/1000Base TX
Gi0/7 disabled routed auto auto 10/100/1000Base TX
Gi0/8 disabled routed auto 100 10/100/1000Base TX
Gi0/9 notconnect routed auto auto 10/100/1000Base TX
Gi0/10 notconnect routed auto auto 10/100/1000Base TX
Gi0/11 disabled routed auto auto unknown
Gi0/12 notconnect routed auto auto unknown
Switch# show interfaces fastethernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative Mode: static access
Operational Mode: down
Administrative Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Voice VLAN: dot1p (Inactive)
Appliance trust: 5
Switch# show running-config interface fastethernet0/2
Building configuration...
Current configuration : 131 bytes
!
interface FastEthernet0/2
switchport mode access
switchport protected
no ip address
mls qos cos 7
mls qos cos override
end
Clear
命令
|
目的
|
clear counters
[interface-id]
|
清除端口计数器
.
|
clear interface
interface-id
|
重置某一端口的硬件逻辑
|
clear line
[number | console 0 | vty number]
|
重置异步串口的硬件逻辑
|
|
Note
clear counters
命令只清除用show interface
所显示的计数,不影响用snmp
得到的计数
|
Switch# clear counters fastethernet0/5
Clear "show interface" counters on this interface [confirm] y
Switch#
*Sep 30 08:42:55: %CLEAR-5-COUNTERS: Clear counter on interface FastEthernet0/5
by vty1 (171.69.115.10)
Switch# clear interface fastethernet0/5
|
命令
|
目的
|
Step 1
|
configure terminal
|
进入配置状态
|
Step 2
|
interface
{vlan vlan-id} | {{fastethernet | gigabitethernet} interface-id} | {port-channel port-channel-number}
|
选择要关闭的端口
|
Step 3
|
shutdown
|
关闭
|
Step 4
|
end
|
退出
|
Step 5
|
show running-config
|
验证
|
|
Switch# configure terminal
Switch(config)# interface fastethernet0/5
Switch(config-if)# shutdown
Switch(config-if)#
*Sep 30 08:33:47: %LINK-5-CHANGED: Interface FastEthernet0/5, changed state to a
administratively down
Switch# configure terminal
Switch(config)# interface fastethernet0/5
Switch(config-if)# no shutdown
Switch(config-if)#
*Sep 30 08:36:00: %LINK-3-UPDOWN: Interface FastEthernet0/5, changed state to up
|
注意
不要手工删除
vlan.dat
文件,可能造成
VLAN
的不完整。 如要删除
vlan
需要用有关的命令来进行
|
|
命令
|
目的
|
Step 1
|
configure terminal
|
进入配置状态
|
Step 2
|
vlan
vlan-id
|
输入一个
VLAN号
, 然后进入
vlan配置状态,可以输入一个新的
VLAN号或旧的来进行修改。
|
Step 3
|
name
vlan-name
|
(可选
)输入一个
VLAN名,如果没有配置
VLAN名,缺省的名字是
VLAN号前面用
0填满的
4位数,如
VLAN0004是
VLAN4的缺省名字
|
Step 4
|
mtu
mtu-size
|
(可选
) 改变
MTU大小
|
Step 5
|
end
|
退出
|
Step 6
|
show vlan
{name vlan-name | id vlan-id}
|
验证
|
Step 7
|
copy running-config startup config
|
(可选
) 保存配置
|
Switch# configure terminal
Switch(config)# vlan 20
Switch(config-vlan)# name test20
Switch(config-vlan)# end
|
命令
|
目的
|
Step 1
|
vlan database
|
进入
VLAN配置状态
|
Step 2
|
vlan
vlan-id name vlan-name
|
加入
VLAN号及
VLAN名
|
Step 3
|
vlan
vlan-id mtu mtu-size
|
(可选
) 修改
MTU大小
|
Step 4
|
exit
|
更新
VLAN数据�觳⑼顺�
|
Step 5
|
show vlan
{name vlan-name | id vlan-id}
|
验证配置
|
Step 6
|
copy running-config startup config
|
保存配置(可选)
|
|
Switch# vlan database
Switch(vlan)# vlan 20 name test20
Switch(vlan)# exit
APPLY completed.
Exiting....
Switch#
|
注意
当删除一个
VLAN
时,原来属于此
VLAN
的端口将处于非激活的状态,直到将其分配给某一
VLAN
。
|
|
命令
|
目的
|
Step 1
|
configure terminal
|
进入配置状态
|
Step 2
|
no vlan
vlan-id
|
删除某一
VLAN.
|
Step 3
|
end
|
退出
|
Step 4
|
show vlan brief
|
验证
|
Step 5
|
copy running-config startup config
|
保存
|
|
|
命令
|
目的
|
Step 1
|
configure terminal
|
进入配置状态
|
Step 2
|
interface
interface-id
|
进入要分配的端口
|
Step 3
|
switchport mode access
|
定义二层口
|
Step 4
|
switchport access vlan
vlan-id
|
把端口分配给某一
VLAN
|
Step 5
|
end
|
退出
|
Step 6
|
show running-config interface
interface-id
|
验证端口的
VLAN号
|
Step 7
|
show interfaces
interface-id
switchport
|
验证端口的管理模式和
VLAN情况
|
Step 8
|
copy running-config startup-config
|
保存配置
|
|
Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface fastethernet0/1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 2
Switch(config-if)# end
Switch#
|
命令
|
目的
|
Step 1
|
configure terminal
|
进入配置状态
|
Step 2
|
interface
interface-id
|
进入端口配置状态
|
Step 3
|
switchport trunk encapsulation
{isl | dot1q | negotiate}
|
配置
trunk封装
ISL 或
802.1Q 或自动协商
|
Step 4
|
switchport mode
{dynamic {auto | desirable} | trunk}
|
配置二层
trunk模式。
|
Step 5
|
switchport access vlan
vlan-id
|
(可选
) 指定一个缺省
VLAN, 如果此端口不再是
trunk
|
Step 6
|
switchport trunk native vlan
vlan-id
|
指定
802.1Q native VLAN号
|
Step 7
|
end
|
退出
|
Step 8
|
show interfaces
interface-id
switchport
|
显示有关
switchport 的配置
|
Step 9
|
show interfaces
interface-id
trunk
|
显示有关
trunk的配置
|
Step 10
|
copy running-config startup-config
|
保存配置
|
Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface fastethernet0/4
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# end
|
Command
|
Purpose
|
Step 1
|
configure terminal
|
进入配置状态
|
Step 2
|
interface
interface-id
|
进入端口配置
|
Step 3
|
switchport mode trunk
|
配置二层口为
trunk
|
Step 4
|
switchport trunk allowed vlan
{add | all | except | remove} vlan-list
|
(可选
) 配置
trunk允许的
VLAN.
使用
add
, all, except, remove
关健字
|
Step 5
|
end
|
退出
|
Step 6
|
show interfaces
interface-id
switchport
|
验证
VLAN配置情况
.
|
Step 7
|
copy running-config startup-config
|
保存配置
|
|
Switch(config)# interface fastethernet0/1
Switch(config-if)# switchport trunk allowed vlan remove 2
Switch(config-if)# end
|
命令
|
目的
|
Step 1
|
configure terminal
|
进入配置状态
|
Step 2
|
interface
interface-id
|
进入配置成
802.1qtrunk的端口
|
Step 3
|
switchport trunk native vlan
vlan-id
|
配置
native VLAN号
|
Step 4
|
end
|
退出
|
Step 5
|
show interfaces
interface-id switchport
|
验证
native VLAN配置
|
Step 6
|
copy running-config startup-config
|
保存配置
|
|
|
Command
|
Purpose
|
Step 1
|
configure terminal
|
进入
Switch 1配置状态
|
Step 2
|
vtp domain
domain-name
|
配置
VTP域
|
Step 3
|
vtp mode server
|
将
Switch 1配置成
VTP server.
|
Step 4
|
end
|
退出
|
Step 5
|
show vtp status
|
验证
VTP的配置
|
Step 6
|
show vlan
|
验证
VLAN
|
Step 7
|
configure terminal
|
进入配置状态
|
Step 8
|
interface
fastethernet 0/1
|
进入
F0/1端口
|
Step 9
|
switchport trunk encapsulation
{isl | dot1q | negotiate}
|
配置
trunk封装
|
Step 10
|
switchport mode trunk
|
配置成
trunk
|
Step 11
|
end
|
退出
|
Step 12
|
show interfaces
fastethernet0/1 switchport
|
验证
VLAN配置
|
Step 13
|
|
在
switch1上的
F0/2上重复
7到
11步骤
|
Step 14
|
|
在
Switch 2的
F0/1,F0/2上重复
7到
11步骤。
|
Step 15
|
show vlan
|
当
trunk已经起来,在
switch2上验证已经学到相关的
vlan配置
|
Step 16
|
configure terminal
|
在
Switch 1上进入配置状态
|
Step 17
|
interface fastethernet0/1
|
进入要配置的端口
|
Step 18
|
spanning-tree vlan 8 port-priority 10
|
将端口权值
10赋与
VLAN 8.
|
Step 19
|
spanning-tree vlan 9 port-priority 10
|
将端口权值
10赋与
VLAN 9.
|
Step 20
|
spanning-tree vlan 10 port-priority 10
|
将端口权值
10赋与
VLAN 10.
|
Step 21
|
exit
|
退回
.
|
Step 22
|
interface fastethernet0/2
|
进入
F0/2
|
Step 23
|
spanning-tree vlan 3 port-priority 10
|
将端口权值
10赋与
VLAN 3.
|
Step 24
|
spanning-tree vlan 4 port-priority 10
|
将端口权值
10赋与
VLAN 4.
|
Step 25
|
spanning-tree vlan 5 port-priority 10
|
将端口权值
10赋与
VLAN 5.
|
Step 26
|
spanning-tree vlan 6 port-priority 10
|
将端口权值
10赋与
VLAN 10.
|
Step 27
|
end
|
退出
|
Step 28
|
show running-config
|
验证配置
|
Step 29
|
copy running-config startup-config
|
保存配置
|
|
|
命令
|
目的
|
Step 1
|
configure terminal
|
进入
Switch 1配置状态
|
Step 2
|
interfa
ce fastethernet 0/1
|
进入
F0/1
|
Step 3
|
switchport trunk encapsulation {isl | dot1q | negotiate} |
配置封装
|
Step 4
|
switchport mode trunk
|
配置
Trunk,缺省是
ISL封装
|
Step 5
|
exit
|
退回
|
Step 6
|
|
在
F0/2口上重复
2-
4步骤
|
Step 7
|
end
|
退出
|
Step 8
|
show running-config
|
验证配置
|
Step 9
|
show vlan
|
验证
switch1已经学到
Vlan
|
Step 10
|
configure terminal
|
进入配置状态
|
Step 11
|
interface fastethernet 0/1
|
进入
F0/1
|
Step 12
|
spanning-tree vlan 2 cost 30
|
设置
Vlan2生成树路径值为
30
|
Step 13
|
spanning-tree vlan 3 cost 30
|
设置
Vlan3生成树路径值为
30
|
Step 14
|
spanning-tree vlan 4 cost 30
|
设置
Vlan4生成树路径值为
30
|
Step 15
|
end
|
退出
|
Step 16
|
|
在
switch1的
F0/2上重复
9-
11步骤设置
VLAN8,9,
10生成树路径值为
30
|
Step 17
|
exit
|
退出
|
Step 18
|
show running-config
|
验证配置
|
Step 19
|
copy running-config startup-config
|
保存配置
|