poj 1562 Oil Deposits(dfs)

                                                                                                  Oil Deposits
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 9732   Accepted: 5335

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

Source

Mid-Central USA 1997
题目大意:求不相邻的@的个数。很裸的dfs
#include<iostream>
using namespace std;
int m,n;
char maze[101][101];
int dir[8][2]={{-1,-1},{-1,0},{-1,1},{0,1},{1,1},{1,0},{1,-1},{0,-1}};
int ans;
bool check(int x,int y)
{
    if(x>=0&&x<m&&y>=0&&y<n&&maze[x][y]=='@')
        return true;
    return false;
}
void dfs(int sx,int sy)
{
    if(check(sx,sy))maze[sx][sy]='*';
    else return;
    for(int i=0;i<8;i++)
    {
        int x=sx+dir[i][0];
        int y=sy+dir[i][1];
        dfs(x,y);
    }
}
int main()
{
    //freopen("test.txt","r",stdin);
    while(scanf("%d%d",&m,&n)&&m)
    {
        ans=0;
        for(int i=0;i<m;i++)
            scanf("%s",maze[i]);
        for(int i=0;i<m;i++)
            for(int j=0;j<n;j++)
                if(maze[i][j]=='@')
                {
                    dfs(i,j);
                    ans++;
                }
        printf("%d\n",ans);
    }
    return 0;
}

 

你可能感兴趣的:(poj 1562 Oil Deposits(dfs))