人见人爱A-B nefu 443

人见人爱A-B

Problem : 443

Time Limit : 1000ms

Memory Limit : 65536K

description

参加过上个月月赛的同学一定还记得其中的一个最简单的题目,就是{A}+{B},那个题目求的是两个集合的并集,今天我们这个A-B求的是两个集合的差,就是做集合的减法运算。(当然,大家都知道集合的定义,就是同一个集合中不会有两个相同的元素,这里还是提醒大家一下)

呵呵,很简单吧?

input

每组输入数据占1行,每行数据的开始是2个整数n(0<=n<=100)和m(0<=m<=100),分别表示集合A和集合B的元素个数,然后紧跟着n+m个元素,前面n个元素属于集合A,其余的属于集合B. 每个元素为不超出int范围的整数,元素之间有一个空格隔开.
如果n=0并且m=0表示输入的结束,不做处理。

output

针对每组数据输出一行数据,表示A-B的结果,如果结果为空集合,则输出“NULL”,否则从小到大输出结果,为了简化问题,每个元素后面跟一个空格.

sample_input

3 3 1 2 3 1 4 7
3 7 2 5 8 2 3 4 5 6 7 8 
0 0

sample_output

2 3 
NULL

 

#include <iostream>
#include <algorithm>
#include <stdio.h>
using namespace std;

int main()
{
    int n,m,data1[150],data2[150],k=1,count;
    while(cin>>n>>m)
    {
        if(n==0&&m==0)
        break;
        for(int i=0;i<n;i++)
        cin>>data1[i];
        for(int i=0;i<m;i++)
        cin>>data2[i];
        sort(data1,data1+n);
        sort(data2,data2+m);
        count=0;
        for(int i=0;i<n;i++)
        {
            k=1;
            for(int j=0;j<m;j++)
            {
                if(data1[i]==data2[j])
                {k=0;count++;break;}
            }
            if(k==1)
            cout<<data1[i]<<" ";
        }
        if(count==n)
        printf("NULL");
        cout<<endl;
    }
    return 0;
}

这道题不难,然而脑残的我竟然忘记初始化了。。。。。

你可能感兴趣的:(人见人爱A-B nefu 443)