人见人爱A^B nefu 444

人见人爱A^B

Problem : 444

Time Limit : 1000ms

Memory Limit : 65536K

description

求A^B的最后三位数表示的整数。
说明:A^B的含义是“A的B次方”

input

输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。

output

对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。

sample_input

2 3
12 6
6789 10000
0 0

sample_output

8
984
1

hint

 

source

hdu

 

#include <iostream>
#include <algorithm>
#include <stdio.h>
using namespace std;

int main()
{
    int a,b,k;
    while(cin>>a>>b)
    {
        if(a==0&&b==0)
        break;
        k=1;
        for(int i=1;i<=b;i++)
        {
            k=(k*a)%1000;
        }
        cout<<k<<endl;
    }
    return 0;
}

很简单,无难度。。。。

你可能感兴趣的:(人见人爱A^B nefu 444)