1037. Magic Coupon (25)

1037. Magic Coupon (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43

提交代码

/*
1037. Magic Coupon (25)
http://www.patest.cn/contests/pat-a-practise/1037
*/
#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <vector>
#include <queue>
#include <map>
#include <algorithm>
#include <string>

using namespace std;

#define N 100001

vector<int> pa1; //  序列1 正数 从大到小 排列
vector<int> na1 ; // 序列1 负数 从小到大 排列
vector<int> pa2; //  序列2 正数 从大到小 排列
vector<int> na2 ; // 序列2 负数 从小到大 排列

bool cmp1(int a, int b)
{
	return a > b ;
}

bool cmp2(int a, int b)
{
	return a < b ;
}

int main()
{
	//freopen("in.txt","r",stdin);
	//freopen("out.txt","w",stdout);
	int i,n,tmpn;
	scanf("%d",&n);
	for(i = 0 ;i < n ; i++)
	{
		scanf("%d",&tmpn);
		if(tmpn > 0 )
			pa1.push_back(tmpn);
		if(tmpn < 0 )
			na1.push_back(tmpn);
	}
	scanf("%d",&n);
	for(i = 0 ;i < n ; i++)
	{
		scanf("%d",&tmpn);
		if(tmpn > 0 )
			pa2.push_back(tmpn);
		if(tmpn < 0 )
			na2.push_back(tmpn);
	}
	int pLen1 = pa1.size();
	int nLen1 = na1.size();
	int pLen2 = pa2.size();
	int nLen2 = na2.size();
	if(pLen1 > 0)
		sort(pa1.begin() , pa1.end() ,cmp1);
	if(nLen1 > 0)
		sort(na1.begin() , na1.end() ,cmp2);
	if(pLen2 > 0)
		sort(pa2.begin() , pa2.end() ,cmp1);
	if(nLen2 > 0)
		sort(na2.begin() , na2.end() ,cmp2);

	int sumc = 0 ;
	for(i = 0 ; i< pLen1 && i < pLen2 ; i++) // 正数相乘
	{
		sumc += pa1[i] * pa2[i] ;
	}
	for(i = 0 ; i< nLen1 && i < nLen2 ; i++) // 负数相乘
	{
		sumc += na1[i] * na2[i] ;
	}
	printf("%d\n",sumc);
	return 0 ;
}


你可能感兴趣的:(1037. Magic Coupon (25))