hdu oj 1171 Big Event in HDU

hdu oj 1171 Big Event in HDU

题目:

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29408    Accepted Submission(s): 10329


Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

Sample Input
    
    
    
    
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

Sample Output
    
    
    
    
20 10 40 40
 

解析:

  • 求得总价值后将其分为两半,以其为总容量再使用背包。
  • 刚学01背包的时候用01背包A掉的,后面发现还可以用多重背包。显然多重背包更为的先进,高效。
  • 01背包教程点此。
  • 多重背包教程点此。

代码:

  • 01背包
  • #include<cstdio>
    #include<string.h>
    int w[5001],dp[255555];
    int main()
    {
    	int n,v,k,sv,sk,i,j;
    	while(1)
        {
            scanf("%d",&n);
            if(n<=0)break;
            j=0,sv=0,sk=0;
            memset(dp,0,sizeof(dp));
            while(n--)
            {
                scanf("%d %d",&v,&k);
                sv+=k*v;
                sk+=k;
                while(k--)
                    w[j++]=v;
            }
            v=sv/2;
            for(i=0;i<sk;i++)
            {
                for(j=v;j>=w[i];j--)
                {
                    dp[j]=dp[j]>(dp[j-w[i]]+w[i])?dp[j]:(dp[j-w[i]]+w[i]);
                }
            }
            printf("%d %d\n",sv-dp[v],dp[v]);
        }
    	return 0;
    }
    


  • 多重背包

你可能感兴趣的:(hdu oj 1171 Big Event in HDU)