hdu 1114 Piggy-Bank 动态规划 之完全背包问题

昨天听了羽哥的讲课,发现自己在dp问题上就是个小白~~

切两道完全背包的题目来练习一下  继续学习背包九讲中

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6079    Accepted Submission(s): 3052


Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 
 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 
 

Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.". 
 

Sample Input
   
   
   
   
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4
 

Sample Output
   
   
   
   
The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.
 


题意很简单 看看能否装满背包 能装满就输出盛满背包价值的最小值 装不满就输出impossible


伪代码:

//w[i]  i硬币的重量 v[i] i硬币的价值 bag 背包的容量

for(i=1;i<=n;i++)

 for(j=w[i];j<=bag;j++)

  if(dp[j]<dp[j-w[i]]+v[i])dp[j]=dp[j-w[i]]+v[i];

//若要求背包的最小值 初始化权为0

//如果要求背包能否装满 并求最小值 那就初始化为最大值 9000000

//若不明白 手工模拟一遍就懂了


#include<stdio.h>
int dp[11000],w[600],v[600];
void init()
{
    int i;
    dp[0]=0;
    for(  i=1;i<=10500;i++)
        dp[i]=50000000;
}
int min(int a,int b)
{
  if(a<b)return a;
  else return b;    
}
int main()
{
      int n,bag,a,b,i,m,j;
      scanf("%d",&n);
      while(n--)
      {
         init();
         scanf("%d%d",&a,&b);
         bag=b-a;
         scanf("%d",&m);
         for(i=1;i<=m;i++)
             scanf("%d%d",&v[i],&w[i]);
         for(i=1;i<=m;i++)
             for(j=w[i];j<=bag;j++)
             dp[j]=min(dp[j],dp[j-w[i]]+v[i]);
         if(dp[bag]>30000000)printf("This is impossible.\n");
         else printf("The minimum amount of money in the piggy-bank is %d.\n",dp[bag]);             
                
      }
      
      
} 








你可能感兴趣的:(动态规划,背包问题)