Ice_cream's world I
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 778 Accepted Submission(s): 455
Problem Description
ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
Input
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.
Output
Output the maximum number of ACMers who will be awarded.
One answer one line.
Sample Input
8 10 0 1 1 2 1 3 2 4 3 4 0 5 5 6 6 7 3 6 4 7
Sample Output
题意:在一个王国里,建立很多瞭望塔,瞭望塔之间连接有围墙。给出瞭望塔个数n,各个塔之间的围墙数m。接着给出m组A B;
表示A B之间有围墙连接,问这些哨塔,围墙把土地分割成了几个部分。
英语渣渣的半天没看懂题意,此题是简单的并查集成环。找出环的个数即是土地的块数。直接上代码:
#include<cstdio>
int tree[1010],count=0;
int find(int x)
{
int r=x;
while(r!=tree[r])
r=tree[r];
return r;
}
void megre(int a,int b)
{
int fa,fb;
fa=find(a);
fb=find(b);
if(fa!=fb)
tree[fa]=fb;
else
count++;
}
int main()
{
int n,m,a,b,i;
while(scanf("%d%d",&n,&m)!=EOF)
{
count=0;//注意清零,wa了一次!!!
for(i=0;i<n;i++)
tree[i]=i;
while(m--)
{
scanf("%d%d",&a,&b);
megre(a,b);
}
printf("%d\n",count);
}
return 0;
}