ACM-模拟之Candy Sharing Game——hdu1034

Candy Sharing Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2897    Accepted Submission(s): 1811


Problem Description
A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy. 
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.
 
Input
The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.
 
Output
For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.
 
Sample Input
   
   
   
   
6 36 2 2 2 2 2 11 22 20 18 16 14 12 10 8 6 4 2 4 2 4 6 8 0
 
Sample Output
   
   
   
   
15 14 17 22 4 8
Hint
The game ends in a finite number of steps because: 1. The maximum candy count can never increase. 2. The minimum candy count can never decrease. 3. No one with more than the minimum amount will ever decrease to the minimum. 4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.
 
Source
Greater New York 2003
 
题目:http://acm.hdu.edu.cn/showproblem.php?pid=1034


hdu上一道模拟题,挺水的。
一些学生围着老师坐成一圈,每个人手里有一些糖。
老师一吹哨子,学生就将糖分给右手边同学,分一半。
如果一个学生手里的糖为奇数,则老师给他一个额外的糖,凑成偶数。
问老师要吹多少次哨子能使得每个学生手里的糖数量相同。
输出吹哨次数与糖的数量。

就是模拟得到糖的情况,若是奇数则+1。
注意边界处的判定。
我是多开了一块数组空间,然后,每次后面的得到前面的人糖。最左面的空间初始化为最右面的空间。
这样一步步模拟就出来了。
判断奇偶还是用位运算,%2要15MS,&1 0MS。

/**************************************
***************************************
*        Author:Tree                 *
*From  :http://blog.csdn.net/lttree  *
* Title : Candy Sharing Game          *
*Source: hdu 1034                     *
* Hint  : 模拟题                      *
***************************************
**************************************/
#include <iostream>
using namespace std;
int arr[100001];
bool judge(int n)
{
    int i;
    for(i=2;i<=n;++i)
        if( arr[1]!=arr[i] )
            return false;
    return true;
}
int main()
{
    int i,test,step;
    while( cin>>test && test )
    {
        for(i=1;i<=test;++i)
            cin>>arr[i];
        step=0;
        while( !judge(test) )
        {
            arr[0]=arr[test];
            for(i=test;i>0;--i)
            {
                arr[i]=(arr[i-1]/2+arr[i]/2);
                // 位运算判断奇偶,肯定比%2快
                if( arr[i]&1 )  ++arr[i];
            }
            ++step;
        }
        cout<<step<<" "<<arr[1]<<endl;
    }
    return 0;
}


你可能感兴趣的:(模拟,ACM,game,sharing,candy,hdu1034)