poj 1083 hdu1050 Moving Tables 贪心问题

Moving Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11544    Accepted Submission(s): 3944


Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

poj 1083 hdu1050 Moving Tables 贪心问题_第1张图片

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

poj 1083 hdu1050 Moving Tables 贪心问题_第2张图片

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
 

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
 

Output
The output should contain the minimum time in minutes to complete the moving, one per line.
 

Sample Input
   
   
   
   
3 4 10 20 30 40 50 60 70 80 2 1 3 2 200 3 10 100 20 80 30 50
 

Sample Output
   
   
   
   
10 20 30
 

Source
Asia 2001, Taejon (South Korea)

这道题见过很多次了~~每次都觉的这样的题目挺难的~~后来仔细研究了一下这种问题~~典型的贪心算法~~~好简单~~汗~~

首先先确定 房间对应的过道

1,2房对应  1过道

3,4房对应 2过道

依次类推 

399,400房 对应200过道

然后 现将输入的房间转化成对应的过道 然后 对对应的过道经过的次数进行累积;

例如样例

用数组a[200]初始化为0

3

10 100 经过 5-50过道 这过道的值都+1 

20 80  经过 10-80过道 这过道的值都+1 

30 50 经过 15-25过道 这过道的值都+1

扫一遍 寻找 a[200]中的最大值 发现 15-25 这10个数都是3 最大 即 15-25这个过道必须得被占用3次

用 3*10(time)就可得出正确结论


#include<stdio.h> 
#include<string.h>
int a[500];
int ans[300];
int main()
{
   int i,j=0;
   for(i=1;i<=400;i++)   //房间对应的过道
   {
       if(i%2==1)j++;
       a[i]=j;               
   }
   int x,s,t,n,temp;
   scanf("%d",&x);
   while(x--)
   {
      memset(ans,0,sizeof(ans));    //初始化过道为0  
      scanf("%d",&n);
      
      while(n--)
      {
          scanf("%d %d",&s,&t);
          if(s>t){temp=s;s=t;t=temp;}  //将移桌子都是从左向右移动的
          for(i=a[s];i<=a[t];i++)      //看看过道被占用了多少次
          {
              ans[i]++;                
          }                       
      }          
      int max=0;
      for(i=1;i<=200;i++)            //统计被占用过道的最大值
      {
        if(max<ans[i])max=ans[i];                              
      }
      printf("%d\n",max*10);    //乘以时间得出正确答案
   } 
}





你可能感兴趣的:(manager,table,Integer,input,each,output)