Max Sum of Max-K-sub-sequence
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3728 Accepted Submission(s): 1317
Problem Description
Given a circle sequence A[1],A[2],A[3]......A[n]. Circle sequence means the left neighbour of A[1] is A[n] , and the right neighbour of A[n] is A[1].
Now your job is to calculate the max sum of a Max-K-sub-sequence. Max-K-sub-sequence means a continuous non-empty sub-sequence which length not exceed K.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases.
Then T lines follow, each line starts with two integers N , K(1<=N<=100000 , 1<=K<=N), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output a line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the minimum start position, if still more than one , output the minimum length of them.
Sample Input
4
6 3
6 -1 2 -6 5 -5
6 4
6 -1 2 -6 5 -5
6 3
-1 2 -6 5 -5 6
6 6
-1 -1 -1 -1 -1 -1
Sample Output
Author
shǎ崽@HDU
Source
HDOJ Monthly Contest – 2010.06.05
Recommend
lcy
题目:http://acm.hdu.edu.cn/showproblem.php?pid=3415
题意:给你一个环形的数列,问你连续长度为k的数的和的最大值,并且输出区间坐标,使坐标字典序最小
分析:把环形转换成直线处理即可,求出累加和数组,用优先队列维护
PS:这回总是是1Y了,就是这种感觉^_^
代码:
#include<cstdio>
#include<iostream>
using namespace std;
const int mm=222222;
int a[mm],q[mm];
int main()
{
int i,l,r,n,k,t,tmp,ans,u,v;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&k);
ans=-2e9;
for(i=1;i<=n;++i)
{
scanf("%d",&a[i]);
a[i+n]=a[i];
if(a[i]>ans)
ans=a[i],u=i-1,v=i;
}
a[0]=0;
for(i=1;i<n*2;++i)
a[i]+=a[i-1];
q[l=r=0]=0;
for(i=1;i<n*2;++i)
{
while(l<=r&&a[q[r]]>a[i])--r;
q[++r]=i;
while(i-q[l]>k)++l;
if(q[l]<i)
{
tmp=a[i]-a[q[l]];
if(tmp==ans&&q[l]+1<u)
u=q[l],v=i;
if(tmp>ans)
{
ans=tmp;
u=q[l],v=i;
}
}
}
printf("%d %d %d\n",ans,(u%n)+1,((v-1)%n)+1);
}
return 0;
}