uva 673 - Parentheses Balance


  Parentheses Balance 

You are given a string consisting of parentheses () and []. A string of this type is said to be correct:

(a)
if it is the empty string
(b)
if A and B are correct, AB is correct,
(c)
if A is correct, (A ) and [A ] is correct.

Write a program that takes a sequence of strings of this type and check their correctness. Your program can assume that the maximum string length is 128.

Input 

The file contains a positive integer n and a sequence of n strings of parentheses () and [], one string a line.

Output 

A sequence of Yes or No on the output file.

Sample Input 

3
([])
(([()])))
([()[]()])()

Sample Output 

Yes
No
Yes

 

#include<stdio.h>
void main()
{int link,top,t,i;
 char s[10000],ch[10000];
 scanf("%d\n",&t);
 while (t--)
 {gets(s);  top=0;
  for (i=0;s[i]!='\0';i++)
  {ch[top]=s[i];
   if ((ch[top-1]=='(')&&(ch[top]==')')) top-=2;
   if ((ch[top-1]=='[')&&(ch[top]==']')) top-=2;
   ++top;ch[top]='\0';
  }
  if (top==0) printf("Yes\n");
        else printf("No\n");
 }
}

你可能感兴趣的:(c,String,File,Integer,input,output)