Humble Numbers
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.
Write a program to find and print the nth element in this sequence
Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
Sample Input
1
2
3
4
11
12
13
21
22
23
100
1000
5842
0
Sample Output
The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.
题意:若一个数的所有素因子是2、3、5、7中的一个或多个,则这个数成为Humble数。求第n个Humble数是多少。
分析:若一个数是Humble数,则它的2、3、5、7倍仍然是Humble数。
设a[i]为第i个Humble数,则a[n] = min(2*a[b2], 3*a[b3], 5*a[b5], 7*a[b7]), b2、b3、b5、b7在不断更新。
还有一点要注意:序数词的写法。
#include<stdio.h>
int Min(int a, int b, int c, int d)
{
int Min1 = a < b ? a : b;
int Min2 = c < d ? c : d;
return Min1 < Min2 ? Min1 : Min2;
}
int main()
{
int n, a[5850], b2, b3, b5, b7;
a[1] = 1;
b2 = b3 = b5 = b7 = 1;
int m = 1;
while(m <= 5842)
{
int tmp = Min(2*a[b2], 3*a[b3], 5*a[b5], 7*a[b7]);
a[++m] = tmp;
if(tmp == 2*a[b2]) b2++;
if(tmp == 3*a[b3]) b3++;
if(tmp == 5*a[b5]) b5++;
if(tmp == 7*a[b7]) b7++;
}
while(~scanf("%d",&n) && n)
{
printf("The %d",n);
if(n % 10 == 1 && n % 100 != 11)
printf("st");
else if(n % 10 == 2 && n % 100 != 12)
printf("nd");
else if(n % 10 == 3 && n % 100 != 13)
printf("rd");
else
printf("th");
printf(" humble number is %d.\n",a[n]);
}
return 0;
}