【PAT1004】Counting Leaves

1004. Counting Leaves (30)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input
2 1
01 1 02
Sample Output
0 1

题意 : 对于一个家族树,输出每层节点中 叶子节点(即没有孩子)的数量

思路 :采用结构体数组表示所有的节点,孩子用链表表示

代码如下
#include <iostream>
using namespace std;

int count[100]={0};
int maxlevel=1;

struct childLink  //孩子链表
{
	int id;
	childLink *next;
	childLink(){next=NULL;}
};

struct Node     //树节点
{
	int childNum;
	childLink *childHead;
	Node(){childNum=0;childHead=NULL;}
}*node;

void countLeaves(int l,int id)        //嵌套求解不同层次节点中叶子节点的个数
{
	childLink *cl = node[id].childHead;
	l++;
	while(cl)
	{		
		if(maxlevel<l)maxlevel=l;
		if(node[cl->id].childNum==0)count[l]++;
		else countLeaves(l,cl->id);
		cl=cl->next;
	}
}

int main()
{
	int n,m;
	int i,j,id;
	cin>>n>>m;
	node = new Node[n+1];
	childLink *cl=0;
	for(i=0;i<m;i++)
	{
		cin>>id;
		cin>>node[id].childNum;
		for(j=0;j<node[id].childNum;j++)
		{
			cl = new childLink;
			cin>>cl->id;
			if(node[id].childHead) cl->next=node[id].childHead;
			node[id].childHead = cl;
		}
	}

	if(node[1].childNum==0){count[0]=1;maxlevel=0;}
	else 
	{
		count[0]=0;
		countLeaves(0,1);
	}
	//cout<<"maxlevel: "<<maxlevel<<endl;
	for(i=0;i<maxlevel;i++)
		cout<<count[i]<<" ";
	cout<<count[i]<<endl;
	system("PAUSE");
	return 0;
}

我自己用的测试案例:
9 4
01 2 02 03
02 1 04
03 3 05 06 07
06 2 08 09
输出结果应为:0 0 3 2

你可能感兴趣的:(struct,tree,each,hierarchy,output)