poj 3254 Corn Fields

Corn Fields
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 5040   Accepted: 2664

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

Source

USACO 2006 November Gold

   简单的状态压缩dp.思路类似于铺地砖。先枚举上层状态再推出该行可行状态然后再计算该层方法数。

#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int maze[15][15];
int state[13][1<<13],ans;
int n,m;

void dfs(int p,int s1,int s2,int d)//p行数.s1上层状态.s2该层状态.d列标。
{
    if(d==m)//状态不冲突
    {
        state[p][s2]+=state[p-1][s1];
        state[p][s2]%=100000000;//避免溢出
        return;
    }
    if((maze[p][d]==0)||(s1&(1<<d))||(s2&(1<<(d-1))))
    {
        dfs(p,s1,s2,d+1);
    }
    else
    {
        dfs(p,s1,s2|(1<<d),d+1);
        dfs(p,s1,s2,d+1);
    }
}
int main()
{
    int i,j;

    while(~scanf("%d%d",&n,&m))
    {
        for(i=1; i<=n; i++)
            for(j=0; j<m; j++)
                scanf("%d",&maze[i][j]);
        memset(state,0,sizeof state);
        state[0][0]=1;
        ans=0;
        for(i=1; i<=n; i++)//枚举行数
            for(j=0; j<(1<<m); j++)//枚举上层状态
                if(state[i-1][j])
                    dfs(i,j,0,0);
        for(i=0; i<(1<<m); i++)
            {
                ans+=state[n][i];
                ans%=100000000;
            }
        printf("%d\n",ans);
    }
    return 0;
}


你可能感兴趣的:(c,算法,ACM)