POJ2452 && BNU2571:Sticks Problem

Description

Xuanxuan has n sticks of different length. One day, she puts all her sticks in a line, represented by S1, S2, S3, ...Sn. After measuring the length of each stick Sk (1 <= k <= n), she finds that for some sticks Si and Sj (1<= i < j <= n), each stick placed between Si and Sj is longer than Si but shorter than Sj.

Now given the length of S1, S2, S3, …Sn, you are required to find the maximum value j - i.

Input

The input contains multiple test cases. Each case contains two lines.
Line 1: a single integer n (n <= 50000), indicating the number of sticks.
Line 2: n different positive integers (not larger than 100000), indicating the length of each stick in order.

Output

Output the maximum value j - i in a single line. If there is no such i and j, just output -1.

Sample Input

4
5 4 3 6
4
6 5 4 3

Sample Output

1
-1
题意:找到一个最长的区间,这个区间中间每个数字都要小于末尾的数,并且要大于区间开头的数,输出符合要求的最大区间长度
思路:先记录每一位数后面连续大于这个数的长度,然后再这个长度里找最大的数,这样可求得最大的区间
 
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int a[50005],dis[50005];//dis记录第i位后面连续有几个数大于第i位的数

int main()
{
    int n,i,j,maxn,flag,ans;
    while(~scanf("%d",&n))
    {
        ans = 0;
        for(i = 1; i<=n; i++)
        {
            scanf("%d",&a[i]);
            dis[i] = 1;//初始化为1
        }
        dis[n+1] = -1;
        for(i = n; i>=0; i--)//找出所有符合要求的长度
        {
            while(a[i]<a[i+dis[i]])
                dis[i]+=dis[i+dis[i]];
        }
        for(i = 1; i<=n; i+=flag+1)//下一个i从最大的那个数位置的下一个开始
        {
            maxn = flag = -1;
            for(j = 0; j<dis[i]; j++)//在这个区间内找出最大的,得到一个长度
            {
                if(a[i+j]>maxn)
                {
                    maxn = a[i+j];
                    flag = j;
                }
            }
            if(flag>ans)
                ans = flag;
        }
        if(ans)
            printf("%d\n",ans);
        else
            printf("-1\n");
    }

    return 0;
}

你可能感兴趣的:(poj,水,BNU)