ACM-贪心之Moving Tables——hdu1050

Moving Tables


Problem Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.

ACM-贪心之Moving Tables——hdu1050_第1张图片

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.

ACM-贪心之Moving Tables——hdu1050_第2张图片

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 

Sample Output

10
20
30


还是贪心算法的题,大体内容,要在一个走廊搬桌子,从第s号房间到第t号房间,可以多组一起搬,但不能同时
搬重合的,例如10-20,30-40可以一起搬,但是10-20,15-30 不能同时搬,求总计用多少时间能搬完桌子(最短时间),
根据题目中所给的房间号,可以发现房间号是上下排的,也就是说,从1-3,4-5 其实是不能同时搬动的。


我输入的时候只存了一侧的桌子号,也就是说输入的3,我存成4,这样就避免1-3,4-5的问题了,然后贪心方法,
排序,计算,出结果。。。


#include <iostream>
using namespace std;

struct table{
	int front,back;
	bool use;
}tb[10001];


int main()
{
	int T,N,total;			//T为有几组数据,N为每组数据有几行数据,total为总用时
	int i,j,temp;			
	table tem;

	cin>>T;
	while(T--)
	{
		//**************************   输入
		cin>>N;
		for(i=0;i<N;++i)
		{
			cin>>tb[i].front>>tb[i].back;

			if(tb[i].front%2==1)
				tb[i].front+=1;
			if(tb[i].back%2==1)
				tb[i].back+=1;

			if(tb[i].front>tb[i].back)
			{
				temp=tb[i].front;
				tb[i].front=tb[i].back;
				tb[i].back=temp;
			}
		
			tb[i].use=true;
		}
		//*************************	   排序

		for(i=0;i<N-1;++i)
			for(j=i+1;j<N;++j)
				if(tb[i].front>tb[j].front)
				{
					tem=tb[i];
					tb[i]=tb[j];
					tb[j]=tem;
				}

		//*************************	   计算值
		total=0;
		for(i=0;i<N;++i)
		{
			if(tb[i].use==false)
				continue;
			
			temp=tb[i].back;

			for(j=i+1;j<N;++j)
			{
				if(tb[j].use==false)
					continue;
				if(tb[j].front>temp)
				{
					tb[j].use=false;
					temp=tb[j].back;
				}
			}
			
			total+=10;
		}
		

		//*************************     输出
		cout<<total<<endl;
		

	}

	return 0;
}

 

你可能感兴趣的:(ACM,tables,贪心,Moving,hdu1050)