POJ Cow Sorting 3270【哈希表+置换群】

Cow Sorting
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 6402   Accepted: 2482

Description

Farmer John's N (1 ≤ N ≤ 10,000) cows are lined up to be milked in the evening. Each cow has a unique "grumpiness" level in the range 1...100,000. Since grumpy cows are more likely to damage FJ's milking equipment, FJ would like to reorder the cows in line so they are lined up in increasing order of grumpiness. During this process, the places of any two cows (not necessarily adjacent) can be interchanged. Since grumpy cows are harder to move, it takes FJ a total of X+Y units of time to exchange two cows whose grumpiness levels are X and Y.

Please help FJ calculate the minimal time required to reorder the cows.

Input

Line 1: A single integer:  N
Lines 2.. N+1: Each line contains a single integer: line  i+1 describes the grumpiness of cow  i

Output

Line 1: A single line with the minimal time required to reorder the cows in increasing order of grumpiness.

Sample Input

3
2
3
1

Sample Output

7

Hint

2 3 1 : Initial order. 
2 1 3 : After interchanging cows with grumpiness 3 and 1 (time=1+3=4). 
1 2 3 : After interchanging cows with grumpiness 1 and 2 (time=2+1=3).

Source

USACO 2007 February Gold

置换群~ 这篇文章对求法解释不错:点击打开链接

利用哈希表加快搜索。

#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

int cow[10010];
int acow[10010];
bool used[10010];
int hash[100100];//注意哈希表的大小 

int solve(int n,int small)
{
	int len=n;
	int i,l;
	int t1,t2;
	int ans=0;
	while(len)
	{
		i=l=0;
		int minx=1<<20;
		int sum=0;
		while(used[i]) i++;
		int begin=i;
		while(++l)//不能写成l++。 
		{
			sum+=cow[i];
			used[i]=1;
			if(minx>cow[i]) minx=cow[i];
			i=hash[acow[i]];
			if(begin==i)break;
		}
		len-=l;
		if(l==1)continue;//一个循环节,返回继续 
		t1=sum+(l-2)*minx;
		t2=sum+minx+(l+1)*small;
		ans+=t1<t2?t1:t2;
	}
	return ans;
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		memset(used,false,sizeof(used));
		for(int i=0;i<n;i++)
		{
			scanf("%d",&cow[i]);
			acow[i]=cow[i];
			hash[cow[i]]=i;
		}
		sort(acow,acow+n);
		printf("%d\n",solve(n,acow[0]));
	}
	return 0;
}


你可能感兴趣的:(POJ Cow Sorting 3270【哈希表+置换群】)