【剑指Offer面试题】 九度OJ1512:用两个栈实现队列

题目链接地址:
http://ac.jobdu.com/problem.php?pid=1512
看到这道题时,梦回考研现场啊。13年厦大计算机专业课的编程题其中一题就是用两个栈实现队列。当时想了很久,可是写了太多,估计扣了不少分。现在看了剑指offer里的代码区区20行。真心点赞!

题目1512:用两个栈实现队列

时间限制:1 秒内存限制:128 兆特殊判题:否提交:3103解决:1041
题目描述:
用两个栈来实现一个队列,完成队列的Push和Pop操作。
队列中的元素为int类型。
输入:
每个输入文件包含一个测试样例。
对于每个测试样例,第一行输入一个n(1<=n<=100000),代表队列操作的个数。
接下来的n行,每行输入一个队列操作:
1. PUSH X 向队列中push一个整数x(x>=0)
2. POP 从队列中pop一个数。
输出:
对应每个测试案例,打印所有pop操作中从队列pop中的数字。如果执行pop操作时,队列为空,则打印-1。
样例输入:
3
PUSH 10
POP
POP
样例输出:
10
-1

思路分析:

用具体例子进行模拟
两个栈s1和s2,Push操作:
直接将入队元素压入到s1栈中;
Pop操作:
直接弹出s2栈的栈顶元素(如果s2栈为空时,则将s1中的元素全部压入到s2中后,再进行弹出栈顶元素)。

代码:

/********************************* ----------------------------------- 【剑指Offer面试题】 九度OJ1512:用两个栈实现队列 ----------------------------------- Author:牧之丶 Date:2015年 Email:[email protected] **********************************/ 
#include<stdio.h>
#include<string>
#include<stack>
#include <iostream>
using namespace std;

/** * 队列的入队元素直接压入s1栈,队列出队元素直接从s2栈弹出 * n代表队列操作的个数 */
void stackToQueue(int n)
{
 stack <int> s1;                   
 stack <int> s2;                  
 int i = 0;
 int x;
 string oper;               
for (int i=0;i<n;i++)
{
    cin>>oper;
    if(oper=="PUSH")  // 将元素压入队尾
    {
        cin>>x;
        s1.push(x);                      // 执行入队操作
    }
    else if (oper=="POP")                                // 将队首元素弹出P
    {
        if(s2.empty()== true )           // 如果s2为空,则将s1中的元素全部弹入到s2中
        {
            while(s1.empty()!=true )
            {
                s2.push(s1.top());
                s1.pop();
            }
        }

        if(s2.empty()!= true )          // 如果s2不为空弹出s2的栈顶元素
        {
            cout<<s2.top()<<endl;
            s2.pop();
        }

        else                           // 如果s2为空,则输出-1
        {
            cout<<"-1"<<endl;
        }
    }
}
}

int main()
{
    int n;
    while (cin>>n)
    {
        stackToQueue(n);
    }
    return 0;
}

/************************************************************** Problem: 1512 Language: C++ Result: Accepted Time:520 ms Memory:1656 kb ****************************************************************/

你可能感兴趣的:(面试题,剑指offer,栈实现队列)