hdu 1312 Red and Black

Red and Black

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5672 Accepted Submission(s): 3689


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input
   
   
   
   
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0

Sample Output
   
   
   
   
45 59 6 13

Source
Asia 2004, Ehime (Japan), Japan Domestic

Recommend
Eddy
#include <stdio.h>
#include<string.h>

int dx[4]={-1,1,0,0};//记录方向
int dy[4]={0,0,1,-1};
int m,n,cnt;
char maze[50][50];//记录地图

void dfs(int px,int py)//回溯搜索
{
    int i,nx,ny;

    for(i=0;i<4;i++)
    {
        nx=px+dx[i];
        ny=py+dy[i];
        if(nx>m||nx<1||ny>n||ny<1||maze[nx][ny]=='#')
            continue;
        maze[nx][ny]='#';
        cnt++;//能走的加一
        dfs(nx,ny);
    }
}
int main()
{
    int x,y,i,j;

    while(scanf("%d%d",&n,&m),m||n)
    {
        getchar();
        cnt=1;
        for(i=1;i<=m;i++)
        {
            for(j=1;j<=n;j++)
            {
                scanf("%c",&maze[i][j]);
                if(maze[i][j]=='@')
                    x=i,y=j;//记录起点
            }
            getchar();
        }
        maze[x][y]='#';
        dfs(x,y);
        printf("%d\n",cnt);
    }
    return 0;
}


你可能感兴趣的:(c,算法,ACM)