POJ2159:Ancient Cipher


总时间限制:1000ms    内存限制:65536kB
描述
Ancient Roman empire had a strong government system with various departments, including a secret service department. Important documents were sent between provinces and the capital in encrypted form to prevent eavesdropping. The most popular ciphers in those times were so called substitution cipher and permutation cipher.
Substitution cipher changes all occurrences of each letter to some other letter. Substitutes for all letters must be different. For some letters substitute letter may coincide with the original letter. For example, applying substitution cipher that changes all letters from 'A' to 'Y' to the next ones in the alphabet, and changes 'Z' to 'A', to the message "VICTORIOUS" one gets the message "WJDUPSJPVT".
Permutation cipher applies some permutation to the letters of the message. For example, applying the permutation <2, 1, 5, 4, 3, 7, 6, 10, 9, 8> to the message "VICTORIOUS" one gets the message "IVOTCIRSUO".
It was quickly noticed that being applied separately, both substitution cipher and permutation cipher were rather weak. But when being combined, they were strong enough for those times. Thus, the most important messages were first encrypted using substitution cipher, and then the result was encrypted using permutation cipher. Encrypting the message "VICTORIOUS" with the combination of the ciphers described above one gets the message "JWPUDJSTVP".
Archeologists have recently found the message engraved on a stone plate. At the first glance it seemed completely meaningless, so it was suggested that the message was encrypted with some substitution and permutation ciphers. They have conjectured the possible text of the original message that was encrypted, and now they want to check their conjecture. They need a computer program to do it, so you have to write one.
输入
Input contains two lines. The first line contains the message engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, so the encrypted message contains only capital letters of the English alphabet. The second line contains the original message that is conjectured to be encrypted in the message on the first line. It also contains only capital letters of the English alphabet.
The lengths of both lines of the input are equal and do not exceed 100.
输出
Output "YES" if the message on the first line of the input file could be the result of encrypting the message on the second line, or "NO" in the other case.
样例输入
            JWPUDJSTVP
            VICTORIOUS
样例输出
             YES

乍看该题是一个简单的替代+移位密码题,解密的时候只需要先对密文替代为明文的字母,然后经过移位表的映射即可得到明文。然而,这里并没有给出替代的长度和移位表,题中只是给出了两个例子,不可直接使用。那么解题方法可以这样:对密文和明文中的字母分别统计其频次,然后排序,最后比较对应位上的频次是否相等,如果相等,则肯定可以通过某种替代+移位得到和明文一致的字符串,否则只要有一位不等,就不能得到明文。具体代码如下:

#include <iostream>
#include <string>
#include<algorithm>
using namespace std;
int main()
{
	int i;
	int str0[26]={0},str1[26]={0};
	string strtmp;
	cin>>strtmp;
	for(i=0;i<strtmp.length();i++)
		str0[strtmp[i]-'A']++;
	cin>>strtmp;
	for(i=0;i<strtmp.length();i++)
		str1[strtmp[i]-'A']++;
	sort(str0,str0+26);
        sort(str1,str1+26);
	for(i=0;i<26;i++)
		if(str0[i]!=str1[i])
		{
			cout<<"NO"<<endl;
			return 0;
		}
	cout<<"YES"<<endl;
	return 0;
}


你可能感兴趣的:(算法,ACM)