hdu 1028 Ignatius and the Princess III 母函数水题,,大家注意了,,我要开始刷母函数了~~

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14352    Accepted Submission(s): 10102


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
   
   
   
   
4 10 20
 

Sample Output
   
   
   
   
5 42 627
 
虽然母函数还不是太懂,,但是拿着模板,还会刷出了一题。。

代码:
#include <stdio.h>
#define MAX 150

int main()
{
	int c1[MAX] , c2[MAX] , n;
	while(~scanf("%d",&n))
	{
		for(int i = 0 ; i <= n ; ++i)
		{
			c1[i] = 1 ;
			c2[i] = 0 ;
		}
		
		for(int i = 2 ; i <= n ; ++i)
		{
			for(int j = 0 ; j <= n ; ++j)
			{
				for(int k = 0 ; j+k <= n ; k+=i)
				{
					c2[j+k] += c1[j] ;
				}
			}
			for(int j = 0 ; j <= n ; ++j)
			{
				c1[j] = c2[j] ;
				c2[j] = 0 ; 
			}
		}
		printf("%d\n",c1[n]);
	}
	return 0 ;
}

与君共勉

你可能感兴趣的:(and,the,PRI,生成函数,Ignatius,母函数,hdu1028)