hdoj 2680 Choose the best route【最短路 dijkstra && SPFA】

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 11559    Accepted Submission(s): 3759



Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases. 
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
   
   
   
   
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
   
   
   
   
1 -1
 

此题按题上说的来做的话容易超时,采取反向建图把唯一的终点当成起点~ 

dijkstra:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#define mem(a, b) memset(a, (b), sizeof(a))
#define Wi(a) while(a--)
#define Si(a) scanf("%d", &a)
#define Pi(a) printf("%d\n", (a))
#define INF 0x3f3f3f3f
#include<algorithm>
using namespace std;
const int mx = 1010;
int map[mx][mx], dis[mx], vis[mx];
int n, m, t;
void init()
{
	for(int i = 1; i <= n; i++)
	{
		for(int j = 1; j <= n; j++)
			map[i][j] = i==j?0:INF;
	}
}
void getmap()
{
	int a, b, c;
	Wi(m){
		scanf("%d%d%d", &a, &b, &c);
		if(map[b][a] > c)	map[b][a] = c;
	}
}
void dijkstra(int s)
{
	mem(vis, 0);
	int i, j, k;
	for(i = 1; i <= n; i++)   dis[i] = map[s][i];
	dis[s] = 0;
	vis[s] = 1;
	for(i = 1; i < n; i++)
	{
		int minn = INF;
		for(j = 1; j <= n; j++)
		{
			if(!vis[j] && dis[j] < minn)
			{
				minn = dis[j];
				k = j;
			}
		}
		if(minn == INF)   break;
		vis[k] = 1;
		for(j = 1; j <= n; j++)
		{
			if(!vis[j])	dis[j] = min(dis[j], dis[k]+map[k][j]);
		}
	}
} 

int main(){
	while(scanf("%d%d%d", &n, &m, &t)!=EOF)
	{
		init();
		getmap();
		dijkstra(t);
		int ans = INF;
		int w, s;  Si(w);
		Wi(w){
			Si(s); 
			if(ans > dis[s])	ans = dis[s];	
		}
		if(ans != INF)	Pi(ans);
		else	printf("-1\n");
	}
	return 0;
}

floyd超时。。。。。

SPFA:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#define mem(a, b) memset(a, (b), sizeof(a))
#define Wi(a) while(a--)
#define Si(a) scanf("%d", &a)
#define Pi(a) printf("%d\n", (a))
#define INF 0x3f3f3f3f
#include<algorithm>
using namespace std;
const int mx = 1010;
int dis[mx], vis[mx];
int n, m, t;
int head[mx], edgenum;
struct node{
	int from, to, val, next;
}; 
node edge[220000];
void init()
{
	edgenum = 0;
	mem(head, -1);
}
void add(int a, int b, int c)
{
	node E = {a, b, c, head[a]};
	edge[edgenum] = E;
	head[a] = edgenum++;
}
void getmap()
{
	int a, b, c;
	Wi(m){
		scanf("%d%d%d", &a, &b, &c);
		add(b, a, c);
	}
}
void spfa(int s)
{
	mem(vis, 0);   mem(dis, 0x3f);
	vis[s] = 1;
	dis[s] = 0;
	queue<int> q;
	q.push(s);
	while(!q.empty()){
		int u = q.front(); q.pop(); vis[u] = 0;
		for(int i = head[u]; i != -1; i = edge[i].next){
			int v = edge[i].to;
			if(dis[v] > dis[u]+edge[i].val){
				dis[v] = dis[u]+edge[i].val;
				if(!vis[v]){
					vis[v] = 1;
					q.push(v);
				}
			}
		}
	}
}
int main()
{
	while(scanf("%d%d%d", &n,&m,&t)!=EOF)
	{
		init();
		getmap();
		spfa(t);
		int ans = INF;
		int w;  Si(w);
		Wi(w){
			int s;  Si(s);
			if(ans > dis[s])	ans = dis[s];
		}
		if(ans != INF)	Pi(ans);
		else	printf("-1\n");
	}
	return 0;
}





你可能感兴趣的:(hdoj 2680 Choose the best route【最短路 dijkstra && SPFA】)