hdu1686 Oulipo

Oulipo

Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 4   Accepted Submission(s) : 3

Font: Times New Roman | Verdana | Georgia

Font Size:  

Problem Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

#include <stdio.h>
#include <string.h>
char ss[11111],s[1111111];
int next[11111];
int cnt;

void getnext(int y) {
  int i=0,j=-1;
  next[0]=-1;

  while(i<y) {
   if(j==-1||ss[i]==ss[j]) {
    i++;j++;
    if(ss[i]==ss[j])
      next[i]=next[j];
    else
      next[i]=j;
   }
   else j=next[j];
 }
}

void KMP(int x,int y){
  int i=0,j=0;

  getnext(y);

  while(i<x) {

   if(j==-1||s[i]==ss[j]){
    i++;j++;
   }
   else j=next[j];

   if(j==y) {cnt++;j=next[j];}  //关键在这里!!!
  }
}

int main()
{
 int t;
 int x,y;
 scanf("%d%*c",&t);

 while(t--){

  scanf("%s%s",ss,s);

  x=strlen(s);
  y=strlen(ss);

  cnt=0;

  KMP(x,y);

  printf("%d/n",cnt);
 }
}
 


你可能感兴趣的:(String,String,File,File,input,output,pair)