HDOJ City hall 1453(模拟)

City hall

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 256    Accepted Submission(s): 160


Problem Description
Because of its age, the City Hall has suffered damage to one of its walls. A matrix with M rows and N columns represents the encoded image of that wall, where 1 represents an intact wall and 0 represents a damaged wall (like in Figure-1).

               1110000111
               1100001111
               1000000011
               1111101111
               1110000111

                   Figure-1

To repair the wall, the workers will place some blocks vertically into the damaged area. They can use blocks with a fixed width of 1 and different heights of {1,2, ..., M}. 

For a given image of the City Hallˇs wall, your task is to determine how many blocks of different heights are needed to fill in the damaged area of the wall, and to use the least amount of blocks.
 

Input
There is only one test case. The case starts with a line containing two integers M and N (1 <= M, N <= 200). Each of the following M lines contains a string with length of N, which consists of ¨1〃s and/or ¨0〃s. These M lines represent the wall.
 

Output
You should output how many blocks of different heights are needed. Use separate lines of the following format:

k Ck

where k劇{1,2, ..., M} means the height of the block, and Ck means the amount of blocks of height k that are needed. You should not output the lines where Ck = 0. The order of lines is in the ascending order of k.
 

Sample Input
   
   
   
   
5 10 1110000111 1100001111 1000000011 1111101111 1110000111
 

Sample Output
   
   
   
   
1 7 2 1 3 2 5 1
 

Source
ACM暑期集训队练习赛(七)
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1415  1981  1455  1452  1430 
 

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
int main()
{
	double l;
	while(scanf("%lf",&l)!=EOF){
		int n;
		double c,t;
		double dp[110];
		double p[110];
		memset(p,0,sizeof(p));
		memset(dp,0,sizeof(dp));
		scanf("%d%lf%lf",&n,&c,&t);
		double vr,v1,v2;
		scanf("%lf%lf%lf",&vr,&v1,&v2);
		for(int i=1;i<=n;i++)
		scanf("%lf",&p[i]);
		p[0]=0;p[n+1]=l;
		double T1=l/vr,time;
		dp[0]=0;
		for(int i=1;i<=n+1;i++){
			dp[i]=INF;
			for(int j=0;j<i;j++){
				double S=p[i]-p[j];
				if(S>c)time=(c/v1)+(S-c)/v2;
				else time=S/v1;
				if(j!=0)time+=t;
				dp[i]=min(dp[i],dp[j]+time);
			}
		}
		if(T1>dp[n+1])
		printf("What a pity rabbit!\n");
		else
		printf("Good job,rabbit!\n");
	}
	return 0;
}


你可能感兴趣的:(HDOJ City hall 1453(模拟))