hdu1004 Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 76824    Accepted Submission(s): 28856


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
   
   
   
   
5 green red blue red red 3 pink orange pink 0
 

Sample Output
   
   
   
   
red pink
 

Author
WU, Jiazhi
 

Source

ZJCPC2004



解题分析:

首先说有两种做法,网上的大多数做法是用C语言做的,主要是定义一个color[][],二维数组和 count[]来分别对每次出现的颜色进行记录。

这里我用的是C++的string 只需要定义color[]; 和 count []; 因为在c++ 中是有string类型,一个数组的元素可以是字符串。

这里还要提示的是数据是Each test case starts with a number N (0 < N <= 1000),因此要注意定义数组大小的时候要定义为1001而不是1000.


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#define MAXN 1000
using namespace std;
int main()
{
    int n, i, j;
    while(scanf("%d", &n) && n!= 0)
    {
int count[MAXN] = {0};
        string str[MAXN], color;
        int max=0;
        for(i = 0; i < MAXN; i++)
str[i]= "";
        for(i=1; i <= n; i++)
        {
            cin >> color;
            for(j=1; j < i; j++)
            {
                if(str[j].compare(color) == 0)
                {
                    count[j]++;    
                    break;
                }
            }
            if(j==i) 
            {
                str[i]=color;
                count[i]++;
            }
        }
        for(i=1; i<=n; i++)
        {
            if(count[i] > count[max])
            {
                max = i;
            }
        }
        cout << str[max] << endl;
    }
return 0;
}





你可能感兴趣的:(hdu1004 Let the Balloon Rise)