九度1464:Hello World for U

题目1464:Hello World for U
时间限制:1 秒
内存限制:128 兆
特殊判题:否
提交:2967
解决:834
题目描述:
Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h    d
e     l
l      r
lowo


That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

输入:
There are multiple test cases.Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

输出:
For each test case, print the input string in the shape of U as specified in the description.

样例输入:
helloworld!
ac.jobdu.com样例输出:
h      !
e     d
l       l
lowor
a    m
c      o
.       c
jobdu.

来源:
2012年浙江大学计算机及软件工程研究生机试真题

 

思路:注意"n1 + n2 + n3 - 2 = N.",最好将n1,n2,n3都取得平均值,即n1=n2=(n+2)/3-1

#include<stdio.h>
#include<string.h>
char a[100];
int main()
{
    int i,j,n,n1,n2,n3,m1,m2;
    while(scanf("%s",a)!=EOF)
    {
       n=strlen(a);
    n1=n2=(n+2)/3-1;
    n3=n-2*n1;
    for(i=0;i<n1;i++)
    {
          printf("%c",a[i]);
    for(j=0;j<n3-2;j++)
     printf(" ");
    printf("%c\n",a[n-i-1]);
    }
    m1=i;m2=n-i;
    for(i=m1;i<m2;i++)
     printf("%c",a[i]);
    puts("");
       memset(a,0,sizeof(0));
    }
    return 0;
}

你可能感兴趣的:(C++,C语言,ACM,world,f,OJ,九度,1464Hello)