杭电 3139 水题

        妹啊,,,做kmp的题,,,从分类里面找的,,结果是一道水题,,,,唉!人生何处不水题,,既然看到了,,顺便水过吧。。。。。。题目:

Soda Surpler

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 103    Accepted Submission(s): 75


Problem Description

杭电 3139 水题_第1张图片
Tim is an absolutely obsessive soda drinker, he simply cannot get enough. Most annoyingly though, he almost never has any money, so his only obvious legal way to obtain more soda is to take the money he gets when he recycles empty soda bottles to buy new ones. In addition to the empty bottles resulting from his own consumption he sometimes find empty bottles in the street. One day he was extra thirsty, so he actually drank sodas until he couldn't afford a new one.
 

Input
Three non-negative integers  e, f, c, where  e < 1000 equals the number of empty soda bottles in Tim's possession at the start of the day,  f < 1000 the number of empty soda bottles found during the day, and 1 <  c < 2000 the number of empty bottles required to buy a new soda.
 

Output
How many sodas did Tim drink on his extra thirsty day?
 

Sample Input
   
   
   
   
9 0 3 5 5 2
 

Sample Output
   
   
   
   
4 9

ac代码:

#include <iostream>
#include <cstdio>
using namespace std;
int main(){
  int begin,find,price;
  while(scanf("%d%d%d",&begin,&find,&price)!=EOF){
    int sum=0;
	int count=begin+find;
	while(count>=price){
	  count=count-price+1;
	  sum++;
	}
	printf("%d\n",sum);
  }
  return 0;
}


你可能感兴趣的:(c,equals,input,output)