Connect the Cities
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6323 Accepted Submission(s): 1823
Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.
Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
Sample Input
1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 33
2 1 2
2 1 3
3 4 5 6
Sample Output
题意:输入n,m,k,分别表示有n个城镇和m个可以修建的路,接下来m行每行u,v,w表示u和v之间可以修建一条路并且花费w,接下来k行,每行一个t,紧跟着t个数表示这t个城镇之间以有路
问为了使全镇相通,还需要修建路的最小花费
赤裸裸的最小生成树
//http://acm.hdu.edu.cn/showproblem.php?pid=3371
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;
const int MAX=500+10;
int father[MAX],rank[MAX];
int sum,num;
struct Edge{
int u,v,w;
}edge[MAX*MAX/10];
bool cmp(Edge a,Edge b){
return a.w<b.w;
}
void makeset(int num){
for(int i=1;i<=num;++i){
father[i]=i;
rank[i]=1;
}
}
int findset(int v){
if(v != father[v])father[v]=findset(father[v]);
return father[v];
}
void Union(int x,int y,int l){
int a=findset(x);
int b=findset(y);
if(a == b)return;
if(rank[a]>rank[b]){
father[b]=a;
rank[a]+=rank[b];
}else{
father[a]=b;
rank[b]+=rank[a];
}
sum+=l;
--num;
}
int main(){
int n,m,k,t,d,a,b;
cin>>t;
while(t--){
cin>>n>>m>>k;
makeset(n);
for(int i=0;i<m;++i){
scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].w);
}
sum=0;
num=n;
for(int i=0;i<k;++i){
scanf("%d%d",&d,&a);
for(int j=0;j<d-1;++j){
scanf("%d",&b);
Union(a,b,0);
}
}
if(num != 1){
sort(edge,edge+m,cmp);
for(int i=0;i<m;++i){
Union(edge[i].u,edge[i].v,edge[i].w);
}
}
if(num == 1)cout<<sum<<endl;
else cout<<"-1"<<endl;
}
return 0;
}