HDOJ 1795 The least one(素数打表)

The least one

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 449    Accepted Submission(s): 161


Problem Description
  In the RPG game “go back ice age”(I decide to develop the game after my undergraduate education), all heros have their own respected value, and the skill of killing monsters is defined as the following rule: one hero can kill the monstrers whose respected values are smaller then himself and the two respected values has none common factor but 1, so the skill is the same as the number of the monsters he can kill. Now each kind of value of the monsters come. And your hero have to kill at least M ones. To minimize the damage of the battle, you should dispatch a hero with minimal respected value. Which hero will you dispatch ? There are Q battles, in each battle, for i from 1 to Q, and your hero should kill Mi ones at least. You have all kind of heros with different respected values, and the values(heros’ and monsters’) are positive.
 

Input
  The first line has one integer Q, then Q lines follow. In the Q lines there is an integer Mi, 0<Q<=1000000, 0<Mi<=10000.
 

Output
  For each case, there are Q results, in each result, you should output the value of the hero you will dispatch to complete the task.
 

Sample Input
   
   
   
   
2 3 7
 

Sample Output
   
   
   
   
5 11
 

 

题目很水,但题目看不懂。赛后翻译,哭成狗。。。

 

题意说:在一个游戏中,英雄杀死怪物的条件有两个:1.英雄必须高于怪物的生命值;2.英雄与怪物的生命值除1之外没有其他公因数。      给出怪物生命值mi,找出最小的能击杀怪物的英雄的生命值,即找出大于mi的最小素数。

 

简单,代码如下:(不打表也能过)

 

#include<cstdio>
#define max 11000
int a[max]={1,1};

void primes()
{
	int i,j;
	for(i=2;i*i<=max;i++)
	{
		if(a[i])
		  continue;
		for(j=i*i;j<max;j=j+i)
		   a[j]=1;
	}
}

int main()
{
	primes();
	int q,m,i;
	scanf("%d",&q);
	while(q--)
	{
		scanf("%d",&m);
		for(i=m+1;;i++)
		   if(!a[i])
		      break;
		printf("%d\n",i);
	}
	return 0;
}


 


你可能感兴趣的:(HDOJ 1795 The least one(素数打表))