hdu 3714 Error Curves(三分)

Error Curves

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1198    Accepted Submission(s): 460


Problem Description
Josephina is a clever girl and addicted to Machine Learning recently. She
pays much attention to a method called Linear Discriminant Analysis, which
has many interesting properties.
In order to test the algorithm's efficiency, she collects many datasets.
What's more, each data is divided into two parts: training data and test
data. She gets the parameters of the model on training data and test the
model on test data. To her surprise, she finds each dataset's test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0.

hdu 3714 Error Curves(三分)_第1张图片

It's very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function's minimum which related to multiple quadric functions. The new function F(x) is defined as follows: F(x) = max(Si(x)), i = 1...n. The domain of x is [0, 1000]. Si(x) is a quadric function. Josephina wonders the minimum of F(x). Unfortunately, it's too hard for her to solve this problem. As a super programmer, can you help her?
 

Input
The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n (n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.
 

Output
For each test case, output the answer in a line. Round to 4 digits after the decimal point.
 

Sample Input
   
   
   
   
2 1 2 0 0 2 2 0 0 2 -4 2
 

Sample Output
   
   
   
   
0.0000 0.5000
 

Author
LIN, Yue
 

Source
2010 Asia Chengdu Regional Contest
 

Recommend
zhouzeyong

读题读了好久,汗。。就是给你n个二次函数,定义域为[0,1000], 求x在定义域中每个x所在的n个函数的最大值的最小值。
有二次函数的性质,很明显不的三分题。。。

代码如下:

#include<iostream>
#include<cstdio>
#include<cmath>
#define eps 1e-12
using namespace std;
struct point
{
    double a,b,c;
};
point data[10010];
int n;
int sgn(double a)
{
    return (a>eps)-(a<-eps);
}
double ff(double x)
{
    double m=data[0].a*x*x+data[0].b*x+data[0].c;
    for(int i=1;i<n;i++)
    m=max(m,data[i].a*x*x+data[i].b*x+data[i].c);
    return m;
}
void dist()
{
    double l,r,mid1,mid2,t1,t2;
    l=0;r=1000;
    do
    {
      mid1=(l+r)*0.5;
      mid2=(mid1+r)*0.5;
      t1=ff(mid1);
      t2=ff(mid2);
      if(t1<t2)
      r=mid2;
      else
      l=mid1;
    }while(l+eps<r);
    printf("%.4lf\n",t1);
}
int main()
{
    int t,i;
    scanf("%d",&t);
     while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
        scanf("%lf%lf%lf",&data[i].a,&data[i].b,&data[i].c);
        dist();
    }

    return 0;
}


你可能感兴趣的:(function,Parameters,performance,each,dataset,Training)