poj 1469 二分图匹配(dfs算法)

COURSES
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 10337
Accepted: 4071

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course) 
  • each course has a representative in the committee 

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format: 

P N 
Count1 Student1 1 Student1 2 ... Student1 Count1 
Count2 Student2 1 Student2 2 ... Student2 Count2 
... 
CountP StudentP 1 StudentP 2 ... StudentP CountP 

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses ?from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N. 
There are no blank lines between consecutive sets of data. Input data are correct. 

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2 3 3 3 1 2 3 2 1 2 1 1 3 3 2 1 3 2 1 3 1 1

Sample Output

YES NO
二分图今天自学,本来是学匈牙利解法,但是这题的代码让我改变了思想,他们说这是匈牙利算法,但是我看不出来,可能是因为没有反转,但是如果用另一种看法来看这题的解法,会感觉就是暴力求解了,我是仿照别人的代码写的,下面我以一种简单的思维解释下这种解法
关键在于dfs这一步,dfs一次只增加一个匹配就return 1,原因很简单,就是m[i]=u,i是新的点,必定增加一条边,这也使dfs变的快些了。这点代码处理很巧妙,要仔细琢磨,有点dp的味道,如果想看匈牙利算法,我觉得还是要用bfs比较明显。
#include<cstdio>
#include<string>
#define N 500
int gp[N][N],vd[N],m[N],n;//存图,存点,存匹配对,人数
int dfs(int u)
{
	int i,t;
	for(i=1;i<=n;i++)
	{
		if(gp[u][i]>0&&vd[i]==0)//寻找可以进行匹配的点
		{
			vd[i]=1;//标记点被访问
			t=m[i];//i点的匹配点
			m[i]=u;//令i和u匹配
			if(t==0||dfs(t))//t==0是表示i点之前没有匹配,若t!=0,因为i与u匹配了,则将t重新寻找匹配,若成功则返回1.
				return 1;
			else
				m[i]=t;
		}
	}
	return 0;
}
int count()
{
	int i,ans=0;
	for(i=1;i<=n;i++)
	{
		memset(vd,0,sizeof(vd));
		ans+=dfs(i);
	}
	return ans;
}
int main()
{
	int c,p,i,j,e,k;
	scanf("%d",&c);
	while(c--)
	{
		memset(gp,0,sizeof(gp));
		memset(m,0,sizeof(m));
		scanf("%d%d",&p,&n);
		for(i=1;i<=p;i++)
		{
			scanf("%d",&k);
			for(j=1;j<=k;j++)
			{
				scanf("%d",&e);
				gp[i][e];
			}
			if(count()==p)
				printf("YES\n");
			else
				printf("NO\n");
		}
		return 0;
	}


你可能感兴趣的:(c,算法,Integer,input,each)