【哥德巴赫猜想】POJ Goldbach's Conjecture 2262

Goldbach's Conjecture
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 41142   Accepted: 15754

Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture:  
Every even number greater than 4 can be  
written as the sum of two odd prime numbers.

For example:  
8 = 3 + 5. Both 3 and 5 are odd prime numbers.  
20 = 3 + 17 = 7 + 13.  
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.)  
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million.  

Input

The input will contain one or more test cases.  
Each test case consists of one even integer n with 6 <= n < 1000000.  
Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

Source

Ulm Local 1998

题意:

输入一个数,把它表示成两个质数的和。

解题思路:

哥德巴赫猜想。

AC代码:


#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#include <algorithm>

using namespace std;

int prime[700000];
bool is_prime[10000000];
int tot;

void solve()
{
    tot=0;
    is_prime[0]=is_prime[1]=1;
    for(int i=2;i<10000000;i++)
        if(!is_prime[i]){
            prime[tot++]=i;
            for(int j=i*2;j<10000000;j+=i){
                is_prime[j]=1;
            }
        }
}

int main()
{
    solve();
    int n;
    while(scanf("%d",&n),n){
        int res=0;
        for(int i=0;prime[i]<=n/2;i++){
            int j=n-prime[i];
            if(!is_prime[j]){
                printf("%d = %d + %d\n",n,prime[i],j);
                break;
            }
        }
    }
    return 0;
}

你可能感兴趣的:(【哥德巴赫猜想】POJ Goldbach's Conjecture 2262)