HDOJ 1051 Wooden Sticks(LIS)



Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15700    Accepted Submission(s): 6451


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
   
   
   
   
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
   
   
   
   
2 1 3
 

这一题和NYOJ的236是一样的,具体题解及题意 见:http://blog.csdn.net/zwj1452267376/article/details/49981029


代码如下:

#include<cstdio>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f
int dp[5010];
struct node
{
	int l,w;
}a[5010];

int cmp(node a,node b)
{
	if(a.w!=b.w)
		return a.w<b.w;
	else
		return a.l<b.l;
}

int max(int a,int b)
{
	return a>b?a:b;
}

int main()
{
	int n,i,j,ans,t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=0;i<n;++i)
		{
			scanf("%d%d",&a[i].l,&a[i].w);
			dp[i]=INF;
		}	
		sort(a,a+n,cmp);
		for(i=n-1;i>=0;--i)//注意是求最长下降子序列,即反向的最长上升子序列 
			*lower_bound(dp,dp+n,a[i].l)=a[i].l;
		printf("%d\n",lower_bound(dp,dp+n,INF)-dp);
	}
	return 0;
} 




你可能感兴趣的:(HDOJ 1051 Wooden Sticks(LIS))