【hdu1232】畅通工程【并查集】

Problem Description
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。
 

Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。
 

Sample Input
   
   
   
   
4 2 1 3 4 3 3 3 1 2 1 3 2 3 5 2 1 2 3 5 999 0 0
 
Sample Output
    
    
    
    
1 0 2 998
 
#include <stdio.h>

int father[1002];

int find(int x)//查找
{
	if(x!=father[x])
		father[x]=find(father[x]);//回溯压缩路径
	return father[x];
}

void Union(int a, int b)//合并
{
	int x=find(a);
	int y=find(b);
	if(x!=y)
		father[y]=x;
}

int main()
{
	int n, m, i, x, y, count;

	while(scanf("%d", &n),n)
	{
		for(i=1; i<=n; i++)
			father[i]=i;

		for(scanf("%d",&m); m>0; m--)
		{
			scanf("%d%d", &x, &y);
			Union(x, y);
		}

		for(count=-1, i=1; i<=n; i++)
			if(father[i]==i)
				count++;
		printf("%d\n", count);

	}
}

你可能感兴趣的:(测试,input,交通,output)