hdu 2391 Filthy Rich

Filthy Rich

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1795    Accepted Submission(s): 817


Problem Description
They say that in Phrygia, the streets are paved with gold. You’re currently on vacation in Phrygia, and to your astonishment you discover that this is to be taken literally: small heaps of gold are distributed throughout the city. On a certain day, the Phrygians even allow all the tourists to collect as much gold as they can in a limited rectangular area. As it happens, this day is tomorrow, and you decide to become filthy rich on this day. All the other tourists decided the same however, so it’s going to get crowded. Thus, you only have one chance to cross the field. What is the best way to do so?

Given a rectangular map and amounts of gold on every field, determine the maximum amount of gold you can collect when starting in the upper left corner of the map and moving to the adjacent field in the east, south, or south-east in each step, until you end up in the lower right corner.
 

Input
The input starts with a line containing a single integer, the number of test cases.
Each test case starts with a line, containing the two integers r and c, separated by a space (1 <= r, c <= 1000). This line is followed by r rows, each containing c many integers, separated by a space. These integers tell you how much gold is on each field. The amount of gold never negative.
The maximum amount of gold will always fit in an int.
 

Output
For each test case, write a line containing “Scenario #i:”, where i is the number of the test case, followed by a line containing the maximum amount of gold you can collect in this test case. Finish each test case with an empty line.
 

Sample Input
   
   
   
   
1 3 4 1 10 8 8 0 0 1 8 0 27 0 4
 

Sample Output
   
   
   
   
Scenario #1: 42

/*题解: 
    动态规划(DP)问题,和数塔很像,这里是用递推做的。
    注意
        1.题目要求  Finish each test case with an empty line.(每个测试案例空一行,最后那一个结果也要空一行) 
        2.选好递推的开始点, 确切的说,要从r+1,c+1开始推 
    */

#include<cstdio>
#include<cstring>
int a[1010][1010],dp[1010][1010];
int max(int a,int b,int c)
{
    int t;
    a>b?t=a:t=b;
    t>c?t=t:t=c;
    return t;
}
int main()
{
    int i,j,k,c,r,T;
    k=0;
    scanf("%d",&T);
    while(T--)
    {
        k++;
        memset(a,0,sizeof(a));
        memset(dp,0,sizeof(dp));
        scanf("%d %d",&r,&c);
        for(i=1; i<=r; i++)
        {
            for(j=1; j<=c; j++)
            {
                scanf("%d",&a[i][j]);
            }
        }
        for(i=r; i>=1; i--)
        {
            for(j=c; j>=1; j--)
            {
                dp[i][j]=a[i][j]+max(dp[i+1][j+1],dp[i+1][j],dp[i][j+1]);
            }
        }
        printf("Scenario #%d:\n",k);
        printf("%d\n",dp[1][1]);
        printf("\n");
    }
    return 0;
}
             


你可能感兴趣的:(c,dp,动态规划,HDU,杭电)