HDOJ 5533 Dancing Stars on Me



Dancing Stars on Me

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 586    Accepted Submission(s): 310


Problem Description
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
 

Input
The first line contains a integer T indicating the total number of test cases. Each test case begins with an integer n , denoting the number of stars in the sky. Following n lines, each contains 2 integers xi,yi , describe the coordinates of n stars.

1T300
3n100
10000xi,yi10000
All coordinates are distinct.
 

Output
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
   
   
   
   
3 3 0 0 1 1 1 0 4 0 0 0 1 1 0 1 1 5 0 0 0 1 0 2 2 2 2 0
 

Sample Output
   
   
   
   
NO YES NO
 

题意:在一个平面上,有n个点,问这些点是否能构成正多边形。

记录每个点与其他n-1个点的最小边,先判断每个点上这些最小边是否都有两条,在判断所有点这些最小边是否都相等,满足这些条件就是正多边形。

代码如下:

#include<cstdio>
#include<cstring>
#include<cmath>
#define INF 0x3f3f3f
int x[105],y[105];
double min_l[105];
int main()
{
	int t,n,i,j,cnt;
	double len;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=0;i<n;++i)
		{
			scanf("%d%d",&x[i],&y[i]);
			min_l[i]=INF;
		}
		int sign=1;
		for(i=0;i<n;++i)
		{
			for(j=0;j<n;++j)
			{
				if(j!=i)
				{
					len=sqrt((x[i]-x[j])*(x[i]-x[j])*1.0+(y[i]-y[j])*(y[i]-y[j])*1.0);
					if(len<min_l[i])
					{
						min_l[i]=len;
						cnt=1;
					}
					else if(len==min_l[i])
						cnt++;
				}
			}
			if(cnt!=2)
			{
				sign=0;
				break;
			}
		}
		for(i=0;i<n;++i)
		{
			for(j=0;j<n;++j)
			{
				if(j!=0&&min_l[i]!=min_l[j])
					sign=0;
			}
		}
		if(sign)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}



你可能感兴趣的:(HDOJ 5533 Dancing Stars on Me)