ACM-计算几何之Toys——poj2318

TOYS

题目:http://poj.org/problem?id=2318

Description

Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.




For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.


Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.


Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.


Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output
0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.


计算几何~\(≧▽≦)/~啦啦啦,

简单的点线之间的关系,

题目很长还是英文,嗯,翻译一下:

就是有一个矩形,用一些线段把这些矩形分块,再输入一些点,判断每个区域里面有几个点。

(精简的翻译能力,(*^__^*) 嘻嘻……,当然点不能在线段上,不能在矩形外面)


就是用叉积来判断,点在线段左面还是右面,如果在右面则判断下一条线段,在左面,就相应区域的点总数++,

最后别忘了,如果还在最后一条线右面,则是最后一个区域的点总数++,

简而言之:5条线段可以分成6个区域

稍微注意一下格式,AC咯~~~


// Toys
#include <iostream>
#include <string.h>
using namespace std;
struct Dian
{
    int x,y;
};
struct Line
{
    Dian a,b;
}line[5001];
int n,m,total[5001];

// 求叉积
int chaji(Dian p0,Dian p1,Dian p2)
{
    return (p1.x-p0.x)*(p2.y-p0.y)-(p2.x-p0.x)*(p1.y-p0.y);
}

void judge(Dian d)
{
    int i;
    // 从第一条线向后遍历,如果点在该线左面,则该下标total++
    for(i=0;i<n;++i)
    {
        if(chaji(line[i].b,d,line[i].a)>0)  continue;
        else    {++total[i];return;}
    }
    // 找到最后都没找到,就是在最后一个区域
    ++total[n];
    return;
}

int main()
{
    int i;
    Dian left_up,right_low,temp;

    while(cin>>n && n)
    {
        cin>>m>>left_up.x>>left_up.y>>right_low.x>>right_low.y;
        memset(total,0,sizeof(total));

        for(i=0;i<n;++i)
        {
            cin>>line[i].a.x>>line[i].b.x;
            line[i].a.y=left_up.y;
            line[i].b.y=right_low.y;
        }
        for(i=0;i<m;++i)
        {
            cin>>temp.x>>temp.y;
            judge(temp);
        }

        // 输出格式
        for(i=0;i<=n;++i)
            cout<<i<<": "<<total[i]<<endl;
        cout<<endl;
    }
    return 0;
}


你可能感兴趣的:(ACM,计算几何,Toys,poj2318,点和线段)