Moo Volume
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 12801 |
|
Accepted: 3690 |
Description
Farmer John has received a noise complaint from his neighbor, Farmer Bob, stating that his cows are making too much noise.
FJ's N cows (1 <= N <= 10,000) all graze at various locations on a long one-dimensional pasture. The cows are very chatty animals. Every pair of cows simultaneously carries on a conversation (so every cow is simultaneously MOOing at all of the N-1 other cows). When cow i MOOs at cow j, the volume of this MOO must be equal to the distance between i and j, in order for j to be able to hear the MOO at all. Please help FJ compute the total volume of sound being generated by all N*(N-1) simultaneous MOOing sessions.
Input
* Line 1: N
* Lines 2..N+1: The location of each cow (in the range 0..1,000,000,000).
Output
There are five cows at locations 1, 5, 3, 2, and 4.
Sample Input
5
1
5
3
2
4
Sample Output
40
Hint
INPUT DETAILS:
There are five cows at locations 1, 5, 3, 2, and 4.
OUTPUT DETAILS:
Cow at 1 contributes 1+2+3+4=10, cow at 5 contributes 4+3+2+1=10, cow at 3 contributes 2+1+1+2=6, cow at 2 contributes 1+1+2+3=7, and cow at 4 contributes 3+2+1+1=7. The total volume is (10+10+6+7+7) = 40.
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
long long a[11000];
int main()
{
int n;
while(scanf("%d",&n)==1)
{
for(int i=1;i<=n;i++) cin>>a[i];
sort(a+1,a+1+n);
long long sum=0;
for(int i=1;i<n;i++)
{
int j=i+1;
sum+=i*(n-i)*(a[j]-a[i]);
}
sum*=2;
cout<<sum<<endl;
}
return 0;
}