hdu 1029 Ignatius and the Princess IV

Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 18626    Accepted Submission(s): 7532


Problem Description
"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 

Output
For each test case, you have to output only one line which contains the special number you have found.
 

Sample Input
   
   
   
   
5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1
 

Sample Output
   
   
   
   
3 5 1
简单题,,用hash就可以,提供两份AC代码:
#include <stdio.h>
#include <string.h>
#define MAX 5000010

int dp[MAX] ;

int main()
{
	int n ;
	while(scanf("%d",&n)!=EOF)
	{
		int index = 0 ;
		memset(dp,0,sizeof(dp)) ;
		for(int i = 0 ; i < n ; ++i)
		{
			int t;
			scanf("%d",&t) ;
			dp[t]++ ;
			if(dp[t]>=(n+1)/2) index = t;
		}
		printf("%d\n",index) ;
	}
	return 0 ;
}

#include <stdio.h>
#include <string.h>
#define MAX 5000010
#define INF -222222222

int dp[MAX] ;

int main()
{
	int n ;
	while(scanf("%d",&n)!=EOF)
	{
		int ans = INF ,index = 0 ;
		memset(dp,0,sizeof(dp)) ;
		for(int i = 0 ; i < n ; ++i)
		{
			int t;
			scanf("%d",&t) ;
			dp[t]++ ;
			if(dp[t]>=ans)
			{
				index = t;
				ans = dp[t] ;
			}
		}
		printf("%d\n",index) ;
	}
	return 0 ;
}

大同小异啦!

你可能感兴趣的:(and,the,PRI,Ignatius,hdu1029)