题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4939
Stupid Tower Defense
Time Limit: 12000/6000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 493 Accepted Submission(s): 129
Problem Description
FSF is addicted to a stupid tower defense game. The goal of tower defense games is to try to stop enemies from crossing a map by building traps to slow them down and towers which shoot at them as they pass.
The map is a line, which has n unit length. We can build only one tower on each unit length. The enemy takes t seconds on each unit length. And there are 3 kinds of tower in this game: The red tower, the green tower and the blue tower.
The red tower damage on the enemy x points per second when he passes through the tower.
The green tower damage on the enemy y points per second after he passes through the tower.
The blue tower let the enemy go slower than before (that is, the enemy takes more z second to pass an unit length, also, after he passes through the tower.)
Of course, if you are already pass through m green towers, you should have got m*y damage per second. The same, if you are already pass through k blue towers, the enemy should have took t + k*z seconds every unit length.
FSF now wants to know the maximum damage the enemy can get.
Input
There are multiply test cases.
The first line contains an integer T (T<=100), indicates the number of cases.
Each test only contain 5 integers n, x, y, z, t (2<=n<=1500,0<=x, y, z<=60000,1<=t<=3)
Output
For each case, you should output "Case #C: " first, where C indicates the case number and counts from 1. Then output the answer. For each test only one line which have one integer, the answer to this question.
Sample Input
Sample Output
Case #1: 12
Hint
For the first sample, the first tower is blue tower, and the second is red tower. So, the total damage is 4*(1+2)=12 damage points.
Author
UESTC
Source
2014 Multi-University Training Contest 7
题意:
给你一段长为n的路,每一个单位长度可以放一种塔,这里有三种塔。
1)对正在经过这座塔的敌人进行 x 每秒伤害的攻击
2)对于已经经过这塔的敌人进行y每秒的伤害攻击
3)对已经经过这个塔的敌人放慢速度,使得原先为 经过一个单位时间为 t的速度变为 t+k
官方题解:http://blog.sina.com.cn/s/blog_6bddecdc0102uzka.html
代码如下:(按照官方题解写得)
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
const int maxn=1617;
typedef __int64 LL;
LL dp[maxn][maxn];
LL n,x,y,z,t;
int main()
{
int T;
int cas = 0;
scanf("%d",&T);
while(T--)
{
scanf("%I64d%I64d%I64d%I64d%I64d",&n,&x,&y,&z,&t);
memset(dp,0,sizeof(dp));
LL ans = n*t*x;//全部放红塔
for(LL i = 1; i <= n; i++)
for(LL j = 0; j <= i; j++)
{
if(j == 0)//没有减缓塔(蓝塔)
dp[i][j]=dp[i-1][j]+t*(i-j-1)*y;
else
dp[i][j]=max(dp[i-1][j-1]+(i-j)*y*(t+(j-1)*z),dp[i-1][j]+(i-j-1)*y*(t+j*z));
ans = max(ans,dp[i][j]+(n-i)*(j*z+t)*(x+(i-j)*y));
}
printf("Case #%d: %I64d\n",++cas,ans);
}
return 0;
}