POJ 2159 Ancient Cipher(我的水题之路——双重加密)

Ancient Cipher
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 20020   Accepted: 6786

Description

Ancient Roman empire had a strong government system with various departments, including a secret service department. Important documents were sent between provinces and the capital in encrypted form to prevent eavesdropping. The most popular ciphers in those times were so called substitution cipher and permutation cipher. 
Substitution cipher changes all occurrences of each letter to some other letter. Substitutes for all letters must be different. For some letters substitute letter may coincide with the original letter. For example, applying substitution cipher that changes all letters from 'A' to 'Y' to the next ones in the alphabet, and changes 'Z' to 'A', to the message "VICTORIOUS" one gets the message "WJDUPSJPVT". 
Permutation cipher applies some permutation to the letters of the message. For example, applying the permutation <2, 1, 5, 4, 3, 7, 6, 10, 9, 8> to the message "VICTORIOUS" one gets the message "IVOTCIRSUO". 
It was quickly noticed that being applied separately, both substitution cipher and permutation cipher were rather weak. But when being combined, they were strong enough for those times. Thus, the most important messages were first encrypted using substitution cipher, and then the result was encrypted using permutation cipher. Encrypting the message "VICTORIOUS" with the combination of the ciphers described above one gets the message "JWPUDJSTVP". 
Archeologists have recently found the message engraved on a stone plate. At the first glance it seemed completely meaningless, so it was suggested that the message was encrypted with some substitution and permutation ciphers. They have conjectured the possible text of the original message that was encrypted, and now they want to check their conjecture. They need a computer program to do it, so you have to write one.

Input

Input contains two lines. The first line contains the message engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, so the encrypted message contains only capital letters of the English alphabet. The second line contains the original message that is conjectured to be encrypted in the message on the first line. It also contains only capital letters of the English alphabet. 
The lengths of both lines of the input are equal and do not exceed 100.

Output

Output "YES" if the message on the first line of the input file could be the result of encrypting the message on the second line, or "NO" in the other case.

Sample Input

JWPUDJSTVP
VICTORIOUS

Sample Output

YES

Source

Northeastern Europe 2004

有两种加密形式:1、将26个字母分别对应其他字母,进行加密;2、将字符串的各个字母的位置顺序乱序。现在给了两个字符串,问是否可以通过以上两种加密形式让第二个字符串加密成第一个字符串。如果可以就输出“YES”,否则输出“NO”。

首先分析这两种加密形式,第一种可以保证每一个字母都可以通过不同的字母代替掉;第二种是说字符串的顺序可以随意替换掉。所以我们只需要保证两个字符串不同频率的字母数量相同就可以了,即是说,字符串中,仅出现1次的字母个数,等于密文中仅出现1次的字母个数; 字符串中,仅出现2次的字母个数,等于密文中仅出现2次的字母个数;……。所以先进行统计各个字母的个数,然后进行排序,最后比较每一位即可。

代码(1AC):
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cstring>

using namespace std;

int first[30];
int second[30];
char str1[110];
char str2[110];

int main(void){
    int i, j;
    int len1, len2, flag;

    while (scanf("%s", str1) != EOF){
        scanf("%s", str2);
        len1 = strlen(str1);
        len2 = strlen(str2);
        memset(first, 0, sizeof(first));
        memset(second, 0, sizeof(second));
        for (i = 0; i < len1; i++){
            first[str1[i] - 'A']++;
        }
        for (i = 0; i < len2; i++){
            second[str2[i] - 'A']++;
        }
        sort(first, first + 26);
        sort(second, second + 26);
        for (flag = 1, i = 0; i < 26; i++){
            if (first[i] != second[i]){
                flag = 0;
                break;
            }
        }
        if (len1 == len2 && flag){
            printf("YES\n");
        }
        else{
            printf("NO\n");
        }
    }
    return 0;
}


你可能感兴趣的:(加密,service,System,input,each,permutation)