题目链接:
Series 1
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 423 Accepted Submission(s): 146
Problem Description
Let A be an integral series {A1, A2, . . . , An}.
The zero-order series of A is A itself.
The first-order series of A is {B1, B2, . . . , Bn-1},where Bi = Ai+1 - Ai.
The ith-order series of A is the first-order series of its (i - 1)th-order series (2<=i<=n - 1).
Obviously, the (n - 1)th-order series of A is a single integer. Given A, figure out that integer.
Input
The input consists of several test cases. The first line of input gives the number of test cases T (T<=10).
For each test case:
The first line contains a single integer n(1<=n<=3000), which denotes the length of series A.
The second line consists of n integers, describing A1, A2, . . . , An. (0<=Ai<=105)
Output
For each test case, output the required integer in a line.
Sample Input
Sample Output
Source
2014 Multi-University Training Contest 6
题目分析:
公式:C(n-1,0)*a[n]-C(n-1,1)*a[n-1]+C(n-1,2)*a[n-2]+...+C(n-1,n-1)*a[n]。
用C(n,k)=C(n,k-1)*(n-k+1)/k即可快速得到一行的二项式系数。
第一道Java题!
代码如下:
import java.util.Scanner;
import java.math.BigInteger;
public class Main {
public static void main(String[] args) {
Scanner cin = new Scanner(System.in);
BigInteger[] a;
a = new BigInteger[3017];
int t, n;
t = cin.nextInt();
while(t--){
n = cin.nextInt();
for (int i = 0; i < n; i++)
a[i] = cin.nextBigInteger();
BigInteger ans = BigInteger.ZERO;
BigInteger c = BigInteger.ONE;
for (int i = 0; i < n; i++) {
BigInteger tmp = c.multiply(a[n-i-1]);
if (i%2 == 0)
ans = ans.add(tmp);
else
ans = ans.subtract(tmp);
tmp = c.multiply(BigInteger.valueOf(n-i-1));
c = tmp.divide(BigInteger.valueOf(i+1));
}
System.out.println(ans);
}
}
}