POJ 2955 DP动态规划

Brackets
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 1659   Accepted: 831

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im n, ai1ai2aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

Source

Stanford Local 2004
#include<stdio.h>
#include<string.h>

int dp[105][105];
char str[105];

bool match(char a,char b)
{
	if(a=='('&&b==')')
		return true;
	if(a=='['&&b==']')
		return true;
	return false;
}

int main()
{
	int i,j,k,l,t;
	while(scanf("%s",str)!=EOF)
	{
		if(strcmp(str,"end")==0)
			break;
		memset(dp,0,sizeof(dp));
		l=strlen(str);
		for(k=2;k<=l;k++)
		{
			for(i=0;i+k-1<l;i++)
			{
				t=i+k-1;
				for(j=i;j<t;j++)
				{
					if(dp[i][t]<dp[i][j]+dp[j+1][t])
						dp[i][t]=dp[i][j]+dp[j+1][t];
					if(match(str[i],str[t]))
					{
						if(dp[i][t]<dp[i+1][t-1]+2)
							dp[i][t]=dp[i+1][t-1]+2;
					}
				}
			}
		}
		printf("%d/n",dp[0][l-1]);
	}
	return 0;
}


你可能感兴趣的:(File,input,character,each,IM,output)