1009. Product of Polynomials (25)-PAT

1009. Product of Polynomials (25)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6
 
  
一开始没有考虑到0的情况~~
#include<iostream>
#include<string>
#include<stdio.h>
using namespace std;
#define N 2002
int main()
{
	int k1,k2,i,j,count;
	float po1[N][2];
	float po2[N][2];
	float res[N][2];
	cin>>k1;
	for(i=0;i<k1;i++){
		cin>>po1[i][0];
		cin>>po1[i][1];
	}
	cin>>k2;
	for(i=0;i<k2;i++){
		cin>>po2[i][0];
		cin>>po2[i][1];
	}
	for(i=0;i<N;i++){
		res[i][0]=-1;
		res[i][1]=0;
	}
	int tmp_ex;
	for(i=0;i<k1;i++){
		for(j=0;j<k2;j++){
			tmp_ex=po1[i][0]+po2[j][0];
			res[tmp_ex][0]=tmp_ex;
			res[tmp_ex][1]+=po1[i][1]*po2[j][1];
		}
	}
	count=0;
	for(i=N-1;i>=0;i--){
		if(res[i][0]!=-1&&res[i][1]!=0){
			count++;
			}
	}
	cout<<count;
	for(i=N-1;i>=0;i--){
		if(res[i][0]!=-1&&res[i][1]!=0)
			printf(" %.0f %.1f",res[i][0],res[i][1]);
	}
	return 0;
}


你可能感兴趣的:(1009. Product of Polynomials (25)-PAT)