poj 2421 Constructing Roads 最小生成树(已经存在几条边) KRUSKAL

Constructing Roads
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 13066   Accepted: 5221

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179
 
 
 
 
 
 
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int fath[110];
int r[11000],u[11000],v[11000],w[11000];
int map[110][110];
int used[110][110];
int find(int x)
{
    return fath[x]==x?fath[x]:fath[x]=find(fath[x]);
}
bool cmp(int i,int j)
{
    return w[i]<w[j];
}
int main()
{
    int n;
    while(scanf("%d",&n)==1)
    {
        memset(used,0,sizeof(used));
        for(int i=1;i<=n;i++) fath[i]=i;
        for(int i=1;i<=n*(n-1)/2;i++) r[i]=i;
        for(int i=1;i<=n;i++) for(int j=1;j<=n;j++) scanf("%d",&map[i][j]);
        int Q;scanf("%d",&Q);
        while(Q--)
        {
            int x,y;scanf("%d%d",&x,&y);
            used[x][y]=used[y][x]=1;
        }
        int tmp=1;//可用边数
        for(int i=1;i<=n;i++)
        {
            for(int j=i;j<=n;j++)
            {
                if(map[i][j]==0) continue;
                if(used[i][j])
                {
                    int x=find(i),y=find(j);
                    fath[x]=y;
                    continue;
                }
                u[tmp]=i,v[tmp]=j,w[tmp++]=map[i][j];
            }
        }
        sort(r+1,r+tmp,cmp);
        int cnt=0;
        for(int i=1;i<tmp;i++)
        {
            int e=r[i];
            int x=find(u[e]),y=find(v[e]);
            if(x!=y)
            {
                cnt+=w[e];
                fath[x]=y;
            }
        }
        printf("%d/n",cnt);
    }
    return 0;
}

你可能感兴趣的:(poj 2421 Constructing Roads 最小生成树(已经存在几条边) KRUSKAL)