Square Coins
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10268 Accepted Submission(s): 7020
Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:
ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.
Your mission is to count the number of ways to pay a given amount using coins of Silverland.
Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.
Sample Input
Sample Output
题意:在一个国度,他们的钱币面值都是平方数,钱币为1, 4, 9,.......289(17^2),给出任意价格,求出该价格在该国度的拆分数。
题解:很明显可以得到乘法式:(1*x*x^2*x^3*.....) * (1*x^4*x^8*x^12*...) * (1*x^9*x^18*x^27*....) * .......
将此乘法式合并得到多项式,指数为n的项的系数就是n的拆分数。
代码如下:
#include<cstdio>
#include<cstring>
int c1[320],c2[320];
int main()
{
int n,i,j,k;
while(scanf("%d",&n)&&n)
{
for(i=0;i<=n;++i)
{
c1[i]=1; c2[i]=0;
}
for(i=2;i<=17;++i)
{
for(j=0;j<=n;++j)
{
for(k=0;k+j<=n;k+=i*i)//修改模板的k+=i为K+=i*i即可
c2[k+j]+=c1[j];
}
for(j=0;j<=n;++j)
{
c1[j]=c2[j];
c2[j]=0;
}
}
printf("%d\n",c1[n]);
}
return 0;
}