Intersection
Time Limit: 4000/4000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 973 Accepted Submission(s): 372
Problem Description
Matt is a big fan of logo design. Recently he falls in love with logo made up by rings. The following figures are some famous examples you may know.
A ring is a 2-D figure bounded by two circles sharing the common center. The radius for these circles are denoted by r and R (r < R). For more details, refer to the gray part in the illustration below.
Matt just designed a new logo consisting of two rings with the same size in the 2-D plane. For his interests, Matt would like to know the area of the intersection of these two rings.
Input
The first line contains only one integer T (T ≤ 10
5), which indicates the number of test cases. For each test case, the first line contains two integers r, R (0 ≤ r < R ≤ 10).
Each of the following two lines contains two integers x
i, y
i (0 ≤ x
i, y
i ≤ 20) indicating the coordinates of the center of each ring.
Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y is the area of intersection rounded to 6 decimal places.
Sample Input
2
2 3
0 0
0 0
2 3
0 0
5 0
Sample Output
Case #1: 15.707963
Case #2: 2.250778
题意,给你两个一样的圆环1和圆环2,让那个求出圆环相交面积。
思路:两个外圆相交面积 - 外圆1内圆2相交面积 - 内圆1外圆2相交面积 + 两个内圆相交面积。
AC代码:
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#define PI acos(-1.0)
#define eps 1e-10
using namespace std;
struct Point//点
{
double x, y;
};
double dist(Point c1, Point c2)//两点间距离
{
return sqrt((c1.x - c2.x) * (c1.x - c2.x) + (c1.y - c2.y) * (c1.y - c2.y));
}
double area(Point c1, double r1, Point c2, double r2)
{
double d = dist(c1, c2);
if(r1 + r2 < d + eps) return 0;
if(d < fabs(r1 - r2) + eps)
{
double r = min(r1, r2);
return PI * r * r;
}
double x = (d * d + r1 * r1 - r2 * r2) / (2 * d);
double t1 = acos(x / r1);
double t2 = acos((d - x) / r2);
return r1 * r1 * t1 + r2 * r2 * t2 - d * r1 *sin(t1);
}
int main()
{
int t, k = 1;
double r, R;//内圆半径 外圆半径
scanf("%d", &t);
while(t--)
{
Point c1, c2;
scanf("%lf%lf", &r, &R);
scanf("%lf%lf", &c1.x, &c1.y);
scanf("%lf%lf", &c2.x, &c2.y);
double R_R = area(c1, R, c2, R);//大大相交面积
double R_r = area(c1, R, c2, r);//大小相交面积
double r_R = area(c1, r, c2, R);//小大相交面积
double r_r = area(c1, r, c2, r);//小小相交面积
printf("Case #%d: %.6lf\n", k++, R_R - R_r - r_R + r_r);
}
return 0;
}